Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Routers are not being avialable for VLANs

We have a problem implementing a VLAN for a client here. The details are

as

follows:

The routers used are Cisco, one 2500 series and the other 1750.2500 is is configured for Internet Access through an ISDN line to ISP and the 1750 is configured for the VPN through a Leased

Line to the ISP.

The 3com 4250 layer 2 switch. has the default configuration. We tried configuring Vlan and

then reset it back to the factory setting.

We require three Vlans to be created in this switch. There are two routers connected to this switch.

All the three Vlans have to have access to the routers.(The routers have to be

part of all the three Vlans.).

We tried tagging the ports attached to the routers and adding these two

ports in all the three Vlans but it does not work. After tagging the routers

not available for any of the Vlans.(does not ping from any of the vlans).

Is there anything to be done on the router side???

Expecting an immediate reply.

Thanks in advance

Regards

Auromira

5 REPLIES
New Member

Re: Routers are not being avialable for VLANs

Unfortunately you need to configure trunking (more than one VLAN on a link) on the connection to the routers, and I know for a fact that ehternet ports on the 2500 cannot do trunking. In order to do trunking ypou need to have a fastethernet port.

Your only real solution is to put all the routers in one vlan. One possible solution would be to configure a secondary address on the ehternet interface, but that would only give you two subnets on one link, not the three you need.

Good luck,

Joe

New Member

Re: Routers are not being avialable for VLANs

You need to configure trunking with DOT1Q encapsulation on the ethernet port on the router, then configure sub interfaces for your vlans.

Also, you router needs to have a fast ethernet interface, you can not trunk to a standard 10 mb ethernet interface

regards

Re: Routers are not being avialable for VLANs

Another remark: To use VLAN trunking on the 1750, you will need the IP plus feature set.

The 2500 wil not do trunking.

Regards,

Leo

New Member

Re: Routers are not being avialable for VLANs

You may need to draw a diagram to clarify. However, here is how I understand the problem: The two routers are connected to the 3com switch (layer 2) and they are on two separate VLANS. Further, I am assuming that the routers belong to separate subnets. Since according to you the 4250 is not a layer 3 switch, I am not surprised that you are not able to ping from one router to the other (assuming the switch is the only connections for the routers). To ping you will need to route between VLANS. Since this is a layer 2 switch, you will not be able to do this. One alternative is to try the equivalent of a "one-armed" router on the 4250. I am not familiar with this switch so you may want to read its documentation, to see how this can be done.

New Member

Re: Routers are not being avialable for VLANs

Try the following on each router (make changes to interface as necessary ie.fastethernet->ethernet etc.)

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address x.x.x.x x.x.x.x

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address x.x.x.x x.x.x.x

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address x.x.x.x x.x.x.x

This should be put on both your routers. Place the native under the correct native VLAN on the switch (the native is not necessary) and change the dot1Q number to correspond to the actual vlan number. Change the ip address to one that is suitable for that VLAN's subnet and on the second router do the same without an ip conflict. On the switch ensure you have a dot1q trunk configured to connect to the physicle port on each router router. Now you mentioned that this switch is a 3Com 4250. I went to the link below to see if it is capable of vlan configuration and after a quick look at the data sheet, there was nothing mentioned of it (which is odd because that is a great sales point). But maybe it is....

http://www.3com.com/products/en_US/detail.jsp?tab=features&pathtype=purchase&sku=WEBBNC4200SYS

278
Views
0
Helpful
5
Replies
CreatePlease to create content