Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing 0r Switching Problem

hi all

i am in campus network.i am using 172.16.0.x 255.255.255.0 for proxy machine.There are 16 subnetwork(VLANS configured for every subnet) with mask /24. now problm starts when i give /16 mask to any machine of any vlan then it is able to brows or ping any device in the network even when i give a differnt gateway to the machine(for example i m giving gateway of vlan 8 to the machine of vlan 2).

and when i did trace route with /16 mask the packet got routed to zonal device and then back to core. and when use /24 i got core svi directly.

vlans are configured at core and zone.

Waitng for help

Singh

2 REPLIES
Hall of Fame Super Silver

Re: Routing 0r Switching Problem

Singh

I am not clear if you really have a problem. It sounds like things are working. But if you do not want things to work when the mask on the workstation is different from the mask on the router, then you should disable proxy arp.

With the workstation mask set at /16 it believes that any address in 172.16 is local and will arp for it rather than forwarding to its gateway. If proxy arp is enabled (and it is enabled by default) then the router will answer the arp and the packets will be forwarded. If you disable proxy arp then the router will not respond to arp when the destination is in a remote subnet. Perhaps this is the behavior that you want.

HTH

Rick

Silver

Re: Routing 0r Switching Problem

I think the zonal device is using proxy-arp. Check out the following link

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094adb.shtml

92
Views
0
Helpful
2
Replies