Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

routing between different networks

I have 2 isolated networks, the 1st is 10.x.x.x and the 2nd is 192.168.x.x. I have a point to point connection between each network. I have multi-interface routers at each end. On the 192.168 side I have one interface assigned a 192.168.68.x address and a 2nd interface assigned a 10.7.1.x address. On the 10.x.x.x side I have a router with 3 interfaces. the 1st is a 10.7.1.x, the 2nd is 10.2.x.x and the 3rd is 10.3.x.x.

With this current configuration in place I have access to all 10.2 and 10.3 devices on my remote network from the 192.168.x.x network. At this juncture I am unable to directly attach and administer devices that lye on the 10.1.x.x, 10.4.x.x, 10.5.x.x and 10.6.x.x networks. However I am able to backdoor into these devices through my 10.2.x.x interface on my firewall at the remote location which provides all the routing required between all the 10.x.x.x networks. This is not an efficient method when it comes to monitoring, backing configs and general administration of these devices.

I have tried modifying the configs that are in place to allow the 192.168.x.x traffic to pass through to all of the 10.x.x.x traffic but have been unsuccessful. I cannot seem to get past my 10.7.x.x interface on the remote router when I attempt to connect to any network other than 10.2 and 3. Its obvious as to why I can get to devices on the 10.2 & 3 networks (because of the other 2 physical interfaces on the remote router). The question is: Do I need to add more interfaces ex. 10.1.x.x, 10.4.x.x, 10.5.x.x, 10.6.x.x to the remote router to gain access to those subnets from my 192.168.0.0 network. I know that creating virtual interfaces is an option, the problem here is the VLANs in place and the physical connections to the ports that lye on these VLANs.

All help and suggestions are appreciated.

4 REPLIES
Green

Re: routing between different networks

What subnet mask are you using on each of the 10.x.x.x interfaces?

Are you using a routing protocol (RIP v1/v2, EIGRP, etc)?

Have you set up any static routes? Where? what?

Gotta know.....

Scott

New Member

Re: routing between different networks

On the router attached to my 192.168 network:

interface Ethernet0

ip address 192.168.68.x 255.255.255.0

!

interface Serial1

ip address 10.7.1.x 255.255.255.0

!

router eigrp 1001

network 10.0.0.0

network 192.168.68.0

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.68.x

ip route 10.1.0.0 255.255.0.0 Serial1 permanent

ip route 10.2.0.0 255.255.0.0 Serial1 permanent

ip route 10.3.0.0 255.255.0.0 Serial1 permanent

ip route 10.4.0.0 255.255.0.0 Serial1 permanent

ip route 10.5.0.0 255.255.0.0 Serial1

ip route 192.168.69.0 255.255.255.0 192.168.55.x

ip route 192.168.70.0 255.255.255.0 192.168.55.x

ip route 192.168.80.0 255.255.255.0 192.168.68.x

!

access-list 1 permit 192.168.55.0 0.0.0.255

access-list 110 permit ip 10.2.0.0 0.0.255.255 192.0.0.0 0.255.255.255

access-list 110 permit ip 192.168.80.0 0.0.0.255 10.2.0.0 0.0.255.255

access-list 110 permit ip any 192.168.80.0 0.0.0.255

access-list 110 permit icmp any any

On the router attached to my 10.x.x.x network:

interface Ethernet0

ip address 10.3.1.x 255.255.255.0 secondary

ip address 10.3.1.x 255.255.255.0

no ip redirects

no ip directed-broadcast

!

interface Ethernet1

ip address 10.2.1.x 255.255.255.0

no ip redirects

no ip directed-broadcast

!

interface Serial0

ip address 10.7.1.x 255.255.255.0

no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.3.1.1

ip route 192.168.45.x 255.255.255.255 10.7.1.1

ip route 192.168.55.0 255.255.255.0 10.7.1.1

ip route 192.168.69.x 255.255.255.255 10.7.1.1

this router does not appear to be using a routing protocol.

New Member

Re: routing between different networks

Can you reach the 10.1.X.X, 10.4.X.X - 10.5.X.X subnets from the router with the 10.2.1.X and 10.3.1.X interfaces? If yes, are there routes on the end devices (10.1.X.X, 10.4.X.X, 10.5.X.X) back to the 192.168.X.X subnets?

New Member

Re: routing between different networks

At this point I am only concerned about reaching 2 devices from the 192.168 network. Here are the routes for each device. One is on the 10.5 network and the other is on the 10.1 network.

10.5.1.60

set interface sc0 50 10.5.1.60/255.255.255.0 10.5.1.255

set interface sc0 up

set interface sl0 0.0.0.0 0.0.0.0

set interface sl0 up

set arp agingtime 1200

set ip redirect enable

set ip unreachable enable

set ip fragmentation enable

set ip route 0.0.0.0/0.0.0.0 10.5.1.1 1

set ip route 10.3.1.0/255.255.255.0 10.5.1.1 1

set ip route 10.2.1.0/255.255.255.0 10.5.1.1 1

set ip route 10.4.1.0/255.255.255.0 10.5.1.1 1

set ip route 10.1.1.0/255.255.255.0 10.5.1.1 1

set ip alias default 0.0.0.0

#permit list

set ip permit enable

set ip permit 10.5.1.35 255.255.255.255

set ip permit 192.168.55.0 255.255.255.0

set ip permit 205.181.5.0 255.255.255.0

set ip permit 209.51.172.x 255.255.255.255

The furthest I can go is 10.3.1.200 (interface on T-1 router)

10.1.1.2

ip route 0.0.0.0 0.0.0.0 209.10.190.x

ip route 10.2.1.0 255.255.255.0 10.1.1.1

ip route 10.5.1.0 255.255.255.0 10.1.1.1

ip route 10.5.1.35 255.255.255.255 10.1.1.1

ip route 192.168.55.0 255.255.255.0 10.6.1.1

ip route 192.168.0.0 255.255.0.0 10.1.1.1

ip route 10.7.0.0 255.255.0.0 10.1.1.1

Cant ping anywhere

315
Views
0
Helpful
4
Replies
CreatePlease to create content