Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing between two ethernet int?

I hve a 4006SGM which acts much like a 2600 router. It has a GigabitEthernet0/0 and a Fastethernet0/0. On Gigabitethernet0/0 I have ip 192.168.0.1, on Fa0/0 I have 158.114.52.41. I would like to have hosts on the 192.168.0.x network access the 158.114.52.x network.

Any Ideas? I cannot seem to get the routing working. I would like to use static routes as nothing should change on this network route wise..

  • Other Network Infrastructure Subjects
5 REPLIES
New Member

Re: Routing between two ethernet int?

I don't know about the 4006SGM specifically but as soon as you put an IP address on an interface on a router then you enable IP processing. Putting IP addresses on 2 interfaces should enable IP routing between them.

There is no need for static routes or any routing protocol between directly connected networks.

Assuming that the hosts (on both 'sides' of the router) have the appropriate default gateway address configured (the IP address of the router interface on their LAN) and both interfaces are up, then the only other option left is that ip routing needs to be enabled. This, surprise, surprise, is done by entering 'ip routing' in global config.

New Member

Re: Routing between two ethernet int?

if I get into the AGM I can ping hosts on each subnet, but on the 192.168.x.x network I cannot ping anything.

Here is some of my config:

interface FastEthernet0/0

description connected to TGN

ip address 158.114.52.41 255.255.254.0

ip nat outside

no ip mroute-cache

speed auto

full-duplex

!

interface GigabitEthernet0/0

description connected to VOIP

ip address 192.168.0.1 255.255.255.0

ip nat inside

no ip mroute-cache

no negotiation auto

!

ip default-gateway 158.114.52.1

ip classless

ip route 0.0.0.0 0.0.0.0 158.114.52.1

ip route 192.168.0.0 255.255.255.0 FastEthernet0/0

sh ip route:

Gateway of last resort is 158.114.52.1 to network 0.0.0.0

158.114.0.0/23 is subnetted, 1 subnets

C 158.114.52.0 is directly connected, FastEthernet0/0

C 127.0.0.0/8 is directly connected, Vlan0

C 192.168.0.0/24 is directly connected, GigabitEthernet0/0

S* 0.0.0.0/0 [1/0] via 158.114.52.1

Every one have the correct gateways and such.

Anonymous
N/A

Re: Routing between two ethernet int?

This line looks like your problem to me:

ip route 192.168.0.0 255.255.255.0 FastEthernet0/0

You are, in effect, telling your router that the 192.168.0.0 network is out FE0/0, when in fact it's out the GE0/0 interface.

Kelly

New Member

Re: Routing between two ethernet int?

I removed the line, but I still cannot ping. I debuged icmp and I get...

01:39:48: ICMP: dst (158.114.52.41) port unreachable sent to 192.168.0.15

New Member

Re: Routing between two ethernet int?

Remove the ip default-gateway command.

208
Views
0
Helpful
5
Replies