Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Highlighted
New Member

Routing between vlan within a cisco3550 router?

Please kindly help me if anyone know how to config a cisco3550 router

such that routing between 2 vlan is possible

The Problem Detail:

Setup

=====

FA0/1 <-> PC A (ip=192.168.70.1, gateway=192.168.70.254)

FA0/2 <-> PC B (ip=192.168.80.1, gateway=192.168.80.254)

Running Config (detail is no shown)

==============

!

ip routing

!

int fa0/1

switchport access vlan 70

switchport mode access

no shutdown

!

int fa0/2

switchport access vlan 80

switchport mode access

no shutdown

!

int vlan 70

ip address 192.168.70.254

no shutdown

!

int vlan 70

ip address 192.168.70.254

no shutdown

!

Diagnostic Information

======================

PC A (ip=192.168.70.1) can ping gateway = 192.168.70.254 but not 80.254 and 80.1

PC B (ip=192.168.80.1) can ping gateway = 192.168.80.254 but not 70.254 and 70.1

The "show ip route" command shows:

C 192.168.70.0/24, VLAN70

C 192.168.80.0/24, VLAN80

I also tried add the vlan 70,80 to the vlan db by :

vlan database

vlan 70 name vlan70

vlan 80 name vlan80

exit

Comment

=======

I have searched the whole cisco site and still just can find the setting mentioned above. If anyone have experience about this issue.Please tell us,thank you

5 REPLIES
Cisco Employee

Re: Routing between vlan within a cisco3550 router?

Do you have an EMI image running on this switch? If you do, configure an logical VLAN interface for VLAN 80 as well. You have it configured only for VLAN 70

If this does not help, paste the output of "sh ver" and "sh ip interface brief"

New Member

Re: Routing between vlan within a cisco3550 router?

Sorry, I have entered the right config for vlan 80 but post the wrong part due to

copy.

The version of IOS is 12.1 but without EMI image

Is EMI image essential ?

All interface is up and line protocol is up

New Member

Re: Routing between vlan within a cisco3550 router?

You need the EMI image, without it you cannot route between vlans

New Member

Re: Routing between vlan within a cisco3550 router?

This is not true, SMI allows routing but does not include support for advanced routing. It uses static and RIP for routing IP traffic.

New Member

Re: Routing between vlan within a cisco3550 router?

Sounds like you have a L3 problem. Try extended ping:

1. from 192.168.70.254 to 192.168.80.1

2. from 192.168.70.254 to 192.168.80.254

3. from 192.168.80.254 to 192.168.70.1

4. from 192.168.80.254 to 192.168.70.254

If both 2&4 are fine but 1&3 are not then you might have the default gateway on the PCs set incorrectly. If all 4 cases work then I guess ... send out an outage notification and give the switch a kick. :-)

147
Views
0
Helpful
5
Replies
CreatePlease login to create content