Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing between VLAN within a cisco3550 router

Please kindly help me if anyone know how to config a cisco3550 router

such that routing between 2 vlan is possible

The Problem Detail:

Setup

=====

FA0/1<->PC A (ip=192.168.70.1, gateway=192.168.70.254)

FA0/2<->PC B (ip=192.168.80.1, gateway=192.168.80.254)

Running Config (detail is no shown)

==============

!

ip routing

!

int fa0/1

switchport access vlan 70

switchport mode access

no shutdown

!

int fa0/2

switchport access vlan 80

switchport mode access

no shutdown

!

int vlan 70

ip address 192.168.70.254

no shutdown

!

int vlan 70

ip address 192.168.70.254

no shutdown

!

Diagnostic Information

======================

PC A (ip=192.168.70.1) can ping gateway = 192.168.70.254 but not 80.254 and 80.1

PC B (ip=192.168.80.1) can ping gateway = 192.168.80.254 but not 70.254 and 70.1

Comment

=======

I have searched the whole cisco site and still just can find the setting mentioned above. If anyone have experience about this issue.Please tell us,thank you

3 REPLIES

Re: Routing between VLAN within a cisco3550 router

Check the status of the VLANs. >> sh int vlan 70

Vlan70 is up, line protocol is up >> this is the correct status

The vlans could very well be down. (line protocol is down) If so, then you forgot to configure the vtp domain. In enable mode type the following:

vlan database

vlan 70 name vlan70

vlan 80 name vlan80

exit

This will fix the problem

New Member

Re: Routing between VLAN within a cisco3550 router

Do you get both the routes in the routing table?

New Member

Re: Routing between VLAN within a cisco3550 router

I tried this by doing the same. But I didnt face any problem at all. I am attaching the configuration as well. You dont have to add the vlan manually. It adds automatically as soon as you enter the command "switchport access vlan " .

Switch#sh run

Building configuration...

Current configuration : 1067 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

ip subnet-zero

ip routing

!

!

spanning-tree extend system-id

!

!

!

interface GigabitEthernet0/1

no switchport

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface GigabitEthernet0/3

no ip address

!

interface GigabitEthernet0/4

no ip address

!

interface GigabitEthernet0/5

no ip address

!

interface GigabitEthernet0/6

no ip address

!

interface GigabitEthernet0/7

no ip address

!

interface GigabitEthernet0/8

no ip address

!

interface GigabitEthernet0/9

no ip address

!

interface GigabitEthernet0/10

no ip address

!

interface GigabitEthernet0/11

switchport access vlan 70

no ip address

!

interface GigabitEthernet0/12

switchport access vlan 80

no ip address

!

interface Vlan1

no ip address

shutdown

!

interface Vlan70

ip address 192.168.70.254 255.255.255.0

!

interface Vlan80

ip address 192.168.80.254 255.255.255.0

!

ip classless

ip http server

!

!

!

!

line con 0

line vty 5 15

!

end

Switch#

-----------------------------------------------------------------------------------------------

r1#sh ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0 192.168.70.1 YES manual up up

r1#sh ip rou

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 192.168.70.254 to network 0.0.0.0

C 192.168.70.0/24 is directly connected, FastEthernet0

S* 0.0.0.0/0 [1/0] via 192.168.70.254

r1#ping 192.168.80.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.80.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

r1#

--------------------------------------------------------------------------------------------------------

r2#sh ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 192.168.80.1 YES manual up up

r2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 192.168.80.254 to network 0.0.0.0

C 192.168.80.0/24 is directly connected, FastEthernet0/0

S* 0.0.0.0/0 [1/0] via 192.168.80.254

r2#

r2#ping 192.168.70.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.70.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

r2#

------------------------------------------------------------------------------------------------------

regards

111
Views
0
Helpful
3
Replies
CreatePlease login to create content