Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing between Vlans on Cat 3750

I'm trying to use the switch 3750 to route between a couple of networks. The switch is connected to the router but I do not want the router to route these two networks.

The default network is 10.20.57.128/25, the second network is 10.57.9.0/28

Here's my config...

sh run

Building configuration...

Current configuration : 2434 bytes

!

! Last configuration change at 04:11:53 UTC Tue Jul 8 2003

! NVRAM config last updated at 02:55:08 UTC Tue Jul 8 2003

!

version 12.1

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

no service password-encryption

!

hostname om3750-1

!

!

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

interface Port-channel1

no ip address

!

interface GigabitEthernet1/0/1

description connection to om3640-1

no switchport

ip address 10.20.57.133 255.255.255.128

shutdown

duplex full

speed 100

!

interface GigabitEthernet1/0/2

no ip address

!

interface GigabitEthernet1/0/3

no ip address

!

interface GigabitEthernet1/0/4

no ip address

!

interface GigabitEthernet1/0/5

no ip address

!

interface GigabitEthernet1/0/6

no ip address

!

interface GigabitEthernet1/0/7

no ip address

!

interface GigabitEthernet1/0/8

no ip address

!

interface GigabitEthernet1/0/9

no ip address

!

interface GigabitEthernet1/0/10

no ip address

!

interface GigabitEthernet1/0/11

no ip address

!

interface GigabitEthernet1/0/12

no ip address

!

interface GigabitEthernet1/0/13

no ip address

!

interface GigabitEthernet1/0/14

no ip address

!

interface GigabitEthernet1/0/15

no ip address

!

interface GigabitEthernet1/0/16

no ip address

!

interface GigabitEthernet1/0/17

no ip address

!

interface GigabitEthernet1/0/18

no ip address

!

interface GigabitEthernet1/0/19

no ip address

!

interface GigabitEthernet1/0/20

description temp connection om3548-1

no ip address

duplex full

speed 100

!

interface GigabitEthernet1/0/21

switchport access vlan 140

switchport mode access

no ip address

duplex full

speed 100

channel-group 1 mode on

!

interface GigabitEthernet1/0/22

switchport access vlan 140

switchport mode access

no ip address

duplex full

speed 100

channel-group 1 mode on

!

interface GigabitEthernet1/0/23

switchport access vlan 140

switchport mode access

no ip address

duplex full

speed 100

channel-group 1 mode on

!

interface GigabitEthernet1/0/24

switchport access vlan 140

switchport mode access

no ip address

duplex full

speed 100

channel-group 1 mode on

!

interface Vlan1

description QA Network

ip address 10.20.57.132 255.255.255.128

!

interface Vlan140

description Backbone Network

ip address 10.57.9.9 255.255.255.240

!

ip default-gateway 10.20.57.129

ip classless

ip http server

!

!

line con 0

line vty 5 15

!

end

Thanks...

2 REPLIES
New Member

Re: Routing between Vlans on Cat 3750

I hope your running EMI software.

you don't need to assign the port connecting to the router an IP address. It can happily live in VLAN 1.

By the looks of your config, you only have 4 ports not in VLAN 1 and they are all configured in a port-channel.

Is you switch configured as a default gateway or are hosts still sending data to the router which is connected to a shut down port?

Can you draw up a picture so I can understand where the router connects back into the 140 VLAN..

Steve

New Member

Re: Routing between Vlans on Cat 3750

Hi Steve,

Thanks for responding.

I am running EMI software on the 3750 and I have a supIV with enhanced software for the Cat4006.

wkstn A 10.20.57.141 ---> cat 3750 ----> 3640 router (10.57.2.129) ---WAN

| |

| |

wkstn B 10.57.2.158----->catalyst 4006 --------------->3640 router (10.57.2.138)

Currently the gateway for wkstn A is 10.57.2.129, gateway for wkstn B 10.57.2.158.

What I am trying to do is when wkstn A needs to talk to wkstn B, I need it to use the cat 3750 to the cat 4006 to wkstn B instead of using the 3640 routers.

What am proposing to do is create two vlans 10.20.57.128/25 and 10.57.9.0/28 on cat3750 and vlans 10.57.2.128/25 and 10.57.9.0/28 on cat4006. When wkstnA wants to talk to wkstnb, it would use the 10.57.9.0 vlan.

The other bug to this is if wkstn A wants to talk to anything in the WAN, it has to use the 3640 routers.

Does this make any sense? I've been trying to explain this to TAC but they don't seem to get it. They're saying I can't do this.

Thanks..JOy

94
Views
0
Helpful
2
Replies