Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

routing or brigding IRB and NAT

Hi!,

we have recently adquired a new 3725 as Internet router. It has a FastEthernet interface to our network and a ATM OC-3 interface to an external provider. We are using NAT because we have not enough public IP addresses. The router is working with 8500 NAT translations and 10 Kpps that are equivalent to 6-7 Mbps. The CPU reaches 40%.

Here is the configuration:

interface Loopback1

description Interfaz de Gestion

ip address 10.0.0.10 255.255.255.255

!

interface Loopback2

ip address y1.y2.y3.1 255.255.255.0

no ip unreachables

no ip proxy-arp

!

interface FastEthernet0/0

ip address 195.57.165.174 255.255.255.248

ip nat inside

speed 100

full-duplex

!

!

interface ATM1/0

no ip address

no atm auto-configuration

no atm ilmi-keepalive

no atm address-registration

no atm ilmi-enable

!

interface ATM1/0.197 point-to-point

description CONEXION ATM 34Mbps RED NURIA de TDATA

bandwidth 8000

ip address x1.x2.x3.x4 255.255.255.252

no ip proxy-arp

ip nat outside

pvc 18/197

vbr-nrt 9360 9360 1

oam-pvc manage 5

oam retry 3 3 5

encapsulation aal5snap

!

!

ip nat translation timeout 300

ip nat translation tcp-timeout 300

ip nat translation dns-timeout 300

ip nat translation max-entries 15000

ip nat service H225 tcp port 19297

ip nat service H225 tcp port 16596

ip nat pool POOL-PUBLICO y1.y2.y3.2 y1.y2.y3.254 netmask 255.255.255.0

ip nat inside source list ACL-NAT pool POOL-PUBLICO overload

ip classless

ip route 0.0.0.0 0.0.0.0 x1.x2.x3.x5

ip route 10.0.0.0 255.0.0.0 195.57.165.169

no ip http server

ip pim bidir-enable

!

!

ip access-list extended ACL-NAT

permit ip 10.10.0.0 0.0.31.255 any

deny ip any any

!

The proccess with higher CPU utilization is IP Input:

46 23499576 53512897 439 21.28% 20.35% 20.68% 0 IP Input

We are using Fast Switching and have tested CEF, but CPU usage is lower with Fast Switching.

The question is: can we increase the performance using bridging? Is possible configure NAT and bridging with IRB? Can we reduce the CPU utilization with IRB? Is there another way to get it?

Thanks in advance.

Antonio M.

1 REPLY
Bronze

Re: routing or brigding IRB and NAT

With IRB I would only expect the CPU utilization to increase.

246
Views
0
Helpful
1
Replies
CreatePlease to create content