Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing problem between two networks

Scenario:

Network A:

Computer A:192.168.1.1 255.255.255.0

Computer B:192.168.1.2 255.255.255.0

Computer C:192.168.1.3 255.255.255.0

Route A :192.168.1.9 255.255.255.0

network B :

Route B:192.168.27.1 255.255.255.0

Computer A:192.168.27.2 255.255.255.0 <-- First NIC

Computer A:192.168.7.1 255.255.255.0 <---second NIC

Computer B:192.168.7.2 255.255.255.0

Computer C:192.168.7.3 255.255.255.0

Router B attached to Fist NIC of server at network B and IP routing enabled at this server. These networks connected through leased line.

From any workstations of network A , can ping to Router A & Router B & first NIC of network B, and From network B can ping to Router A & Router B but no beyond them ( Routing enables on server ).

Here are two routers' configuration . How can set them to pass packets from network A to B and vice versa?

Thanks

Router A

--------

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname Router_A

!

interface Ethernet0

ip address 192.168.1.9 255.255.255.0

!

interface Serial0

ip unnumbered Ethernet0

encapsulation ppp

!

interface Serial1

no ip address

shutdown

shutdown

!

interface Serial2

no ip address

shutdown

!

interface Serial3

no ip address

shutdown

!

interface Serial4

no ip address

shutdown

!

interface Serial5

no ip address

shutdown

!

interface Serial6

no ip address

shutdown

!

interface Serial7

no ip address

no ip address

shutdown

!

interface Serial8

no ip address

shutdown

!

interface Serial9

no ip address

shutdown

!

interface BRI0

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.3

ip route 192.168.1.0 255.255.255.0 Ethernet0

ip route 192.168.7.0 255.255.255.0 192.168.27.1

ip route 192.168.27.0 255.255.255.0 Serial0

!

line con 0

line aux 0

line vty 0 4

login

!

end

Router B

--------

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname Router_B

!

interface Ethernet0

ip address 192.168.27.1 255.255.255.0

!

interface Serial0

ip unnumbered Ethernet0

encapsulation ppp

!

interface Serial1

no ip address

shutdown

shutdown

!

interface Serial2

no ip address

shutdown

!

interface Serial3

no ip address

shutdown

!

interface Serial4

no ip address

shutdown

!

interface Serial5

no ip address

shutdown

!

interface Serial6

no ip address

shutdown

!

interface Serial7

no ip address

no ip address

shutdown

!

interface Serial8

no ip address

shutdown

!

interface Serial9

no ip address

shutdown

!

interface BRI0

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 serial 0

ip route 192.168.1.0 255.255.255.0 192.168.1.9

ip route 192.168.7.0 255.255.255.0 192.168.27.2

ip route 192.168.27.0 255.255.255.0 ethernet 0

!

line con 0

line aux 0

line vty 0 4

login

!

end

4 REPLIES
New Member

Re: Routing problem between two networks

Perhaps you must add second NIC of computer A in network B (192.168.27.2) as next hop for network 192.168.7.0 in router A:

ip route 192.168.7.0 255.255.255.0 192.168.27.2

instead of :

ip route 192.168.7.0 255.255.255.0 192.168.27.1.

Hope that help.

Re: Routing problem between two networks

First of all i would suggest you to clean up certain routes you have added in each router.

On router A

ip route 0.0.0.0 0.0.0.0 192.168.1.3 - instead of this make it point to serial 0. Your default route points to Computer-3

ip route 192.168.1.0 255.255.255.0 Ethernet0 - there is no need for this (directly connected)

ip route 192.168.7.0 255.255.255.0 192.168.27.1 - if you have a default route as in step 1, there is no need for this.

ip route 192.168.27.0 255.255.255.0 Serial0 - since you have default route as in step 1 there is no need for this.

So concluding the configs of router A, just one default route pointing to serial0 should work.

Or you can just add 2 statements..on router A.

ip route 192.168.7.0 255.255.255.0 serial 0

ip route 192.168.27.0 255.255.255.0 serial 0

Similarly on router B

ip route 0.0.0.0 0.0.0.0 serial 0 - this would work fine.

ip route 192.168.1.0 255.255.255.0 192.168.1.9 - - no need since there is default route

ip route 192.168.7.0 255.255.255.0 192.168.27.2 - needed.

ip route 192.168.27.0 255.255.255.0 ethernet 0 - no need, since its directly connected.

In summary,

ip route 0.0.0.0 0.0.0.0 serial 0

ip route 192.168.7.0 255.255.255.0 192.168.7.2

These 2 should work fine.

Servers NIC 1 should point to 192.168.7.1 as default gateway.

New Member

Re: Routing problem between two networks

Yes Shanky, that is.

New Member

Re: Routing problem between two networks

Hi Shanky

It works fine.

Thanks

117
Views
0
Helpful
4
Replies
CreatePlease login to create content