Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing Problem thats driving me crackers

I have a Web Server that has the address 10.252.10.8/24 this is on a vlan located on a L3 switch. The Vlan Gateway address is 10.252.10.1/24 When I try to access the server from a client on the same Vlan with an address 10.252.10.247 configured to use the Vlan Gateway 10.252.10.1 I cannot access the server, even if I place a static route pointing to that server ie ip route 0.0.0.0 0.0.0.0 10.252.10.8. The switch itself is running OSPF and all other routing is working fine.

If I change the Client Gateway address to that of the server then I can access the server but not the rest of the network..

Any suggestion anyone ?

6 REPLIES

Re: Routing Problem thats driving me crackers

Could you post the running configuration of the switch?

New Member

Re: Routing Problem thats driving me crackers

This is a portion of the code pertaining to the layer 3 configration..

interface Vlan252

ip address 10.252.10.2 255.255.255.0

standby 99 ip 10.252.20.1

standby 99 priority 120

standby 99 preempt

!

interface Vlan911

description DOCKLANDS-Production

ip address 10.251.10.2 255.255.255.0

standby 10 ip 10.251.10.1

standby 11 ip 10.252.10.1

standby 11 priority 120

standby 11 preempt

interface Vlan921

description DOCKLANDS_DRAC

ip address 10.251.20.2 255.255.255.0

standby 21 ip 10.251.20.1

!

router ospf 10

log-adjacency-changes

network 10.250.1.0 0.0.0.255 area 0

network 10.251.10.0 0.0.0.255 area 0

network 10.251.20.0 0.0.0.255 area 0

network 10.252.10.0 0.0.0.255 area 0

network 192.168.21.0 0.0.0.255 area 0

ip route 0.0.0.0 0.0.0.0 10.252.10.8

Thanks

Mike

Purple

Re: Routing Problem thats driving me crackers

why is the standby ip in a different subnet on the 252 SVI , you have an ip address of 10.252.10.2 but your virtual ip is 10.252.20.1 ? It has to be in the same subnet such as 10.252.10.1 .

Re: Routing Problem thats driving me crackers

Hi,

you have

interface Vlan252

ip address 10.252.10.2 255.255.255.0

standby 99 ip 10.252.20.1

and

interface Vlan911

description DOCKLANDS-Production

ip address 10.251.10.2 255.255.255.0

standby 10 ip 10.251.10.1

standby 11 ip 10.252.10.1

So the network 10.252.10.0/24 is in two VLANs?!

This could explain the observed behaviour.

Can you make sure all hosts with IPs from 10.252.10.0/24 are located in one VLAN only and also remove the standby with 10.252.10.1 from any other VLAN?

This should finally solve your problems.

Could be your L3 switch gets routing problems in your setup.

Can you post a "show ip route" please? This should further clarify the situation.

Hope this helps! Please rate all posts.

Regards, Martin

Re: Routing Problem thats driving me crackers

Hi Mike,

I see that you have assigned standby ip as 10.252.20.1 for VLAN 252 whose base address is in the subnet 10.252.10.0. Was it a typo?

Also since you have HSRP configured on your network can you post the config of the other HSRP peer?

Narayan

New Member

Re: Routing Problem thats driving me crackers

Yes straight after I pasted the config I spotted my errors..... goes away with head in hands muttering rude things about himself..

I have amended them and its all working now

thanks people

143
Views
0
Helpful
6
Replies