Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

routing problem

My lead IP(A.A.A.125) given to Serial Port is the IP ADDRESS LOGGED

on other side of the conection which are made by my server with ip

address (B.B.B.226,B.B.B.227,B.B.B.228,B.B.B.229.............................)

I tried a connection through a machine which had un-natted ip address (B.B.B.237). Even

in this case the ip address on the other side was A.A.A.125

I want same ip, i.e B.B.B.237 to be reflected @ the other side of the connection for un-nated ip's.

check my configuration below

regds

RamP

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0 secondary

ip address B.B.B.225 255.255.255.224

ip access-group 102 in

ip access-group 101 out

no ip directed-broadcast

ip nat inside

!

interface Serial0

backup delay 1 60

backup interface BRI0

ip address A.A.A.125 255.255.255.252

ip access-group 101 in

ip access-group 102 out

no ip directed-broadcast

ip nat outside

custom-queue-list 1

!

interface BRI0

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer idle-timeout 300

dialer string 28529200

dialer hold-queue 10

dialer-group 1

isdn switch-type basic-net3

ppp authentication pap callin

ppp pap sent-username xxxxx.in password xxxxx

!

ip nat inside source route-map rtm-nat-bri0 interface BRI0 overload

ip nat inside source route-map rtm-nat-ser0 interface Serial0 overload

ip nat inside source static 192.168.201.12 B.B.B.236

ip nat inside source static 192.168.201.11 B.B.B.235

ip nat inside source static 192.168.201.10 B.B.B.234

ip nat inside source static B.B.B.226 A.A.A.125

ip nat inside source static 192.168.201.3 B.B.B.227

ip nat inside source static 192.168.201.4 B.B.B.228

ip nat inside source static 192.168.201.5 B.B.B.229

ip nat inside source static 192.168.201.6 B.B.B.230

ip nat inside source static 192.168.201.7 B.B.B.231

ip nat inside source static 192.168.201.8 B.B.B.232

ip nat inside source static 192.168.201.9 B.B.B.233

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 BRI0 100

ip route 192.168.201.0 255.255.255.0 192.168.1.5

!

route-map rtm-nat-ser0 permit 10

match interface Serial0

!

route-map rtm-nat-bri0 permit 10

match interface BRI0

2 REPLIES
New Member

Re: routing problem

Hi.

I think you can solve your problem , using access-lists and joint them to your route-map

access-list 101 permit ip any any

access-list 102 permit ip any 217.0.0.0 0.255.255.255

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip list 102

route-map INTERNET permit 10

match ip address 102

match interface Dialer2

!

route-map Central-office permit 10

match ip address 101

match interface Dialer1

!

Only ip's matched against an access-list will be natted,

I hope it helps you

Manel

mvr
New Member

Re: routing problem

Hi !!

If you only want to NAT the staically defined addresses, then you should just remove the 2 dynamic NAT statements using route-maps.

The reason you see the example IP as .125 is that it matches on the route-map and gets PAT'ed to the interface address.

Regards

Mikael

95
Views
0
Helpful
2
Replies
CreatePlease to create content