Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Routing Problem

I have got a LINUX PC with 2 NIC, NIC-1 eth0 192.168.1.1/24 & NIC-2 eth1 172.16.1.1/16,

2 Clients PC's, PC-1 10.2.1.1/24 & PC-2 10.2.9.1/24, configured VLAN on 3750, no gateway is set for the LINUX, default route is "route add -net 0.0.0.0 netmask 0.0.0.0 gw 0.0.0.0".

now from PC-1 & PC-2 i can able to reach the LINUX's both NIC's, when eth1 link goes down, i can able to reach eth0, but when eth0 goes down, i can't able to reach eth1, any thing else to be done on the switch side? i also tried, diff. route add commands in linux...

"route add -net 10.2.1.0 netmask 25.255.255.0 gw 192.168.1.252"

"route add -net 10.2.9.0 netmask 25.255.255.0 gw 192.168.1.252"

"route add -net 10.2.9.0 netmask 25.255.255.0 gw 172.16.1.252"

"route add -net 10.2.1.0 netmask 25.255.255.0 gw 172.16.1.252"

what ever commands i put at last,that is acting as a primary interface, which means when that primary interface goes down, the other interface will also go down, so how do i over come with this?

Note: i also tried putting the same subnet IP in eth0 & eth1, nothing worked out.

Cisco 3750 configuration

ip routing

interface vlan 2

ip address 192.168.1.252 255.255.255.0

interface vlan 3

ip address 172.16.1.252 255.255.0.0

interface vlan 4

ip address 10.2.1.252 255.255.255.0

interface vlan 5

ip address 10.2.9.252 255.255.255.0

router eigrp 1

network 10.0.0.0

network 172.16.0.0

network 192.168.1.0

4 REPLIES

Re: Routing Problem

Hi

Few things i would suggest to check out here.

1.Current routes configured in ur linux box,pls recheck the routes and remove the unwanted route statements from the boz.

2.Also can you post the full running config of your switch ?

3.Also whats the ip address/mask/default gateway configuration in your pcs ? can you recheck them once ..

regds

Re: Routing Problem

i just installed the linux & no routes are configured in that.

2 Clients are able to ping the linux 2 NIC by default.

IP address of 2 Client PC are

10.2.1.2/24 gw 10.2.1.252

10.2.9.2/24 gw 10.2.9.252

Cisco 3750 config.

3750#sh run

Building configuration...

Current configuration : 10897 bytes

!

! NVRAM config last updated at 07:20:56 UTC Thu Feb 9 2006 by anand

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 3750

!

enable password 7 011113256500E12

!

username user privilege 5 password 7 00110003160A5955

no aaa new-model

switch 1 provision ws-c3750g-24t

ip subnet-zero

ip domain-name ueltv.org

!

!

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet1/0/1

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/2

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/3

switchport access vlan 4

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/4

switchport access vlan 5

switchport mode access

spanning-tree portfast

interface Vlan2

ip address 192.168.1.252 255.255.255.0

no ip route-cache

no ip mroute-cache

interface Vlan3

ip address 172.16.1.252 255.255.0.0

no ip route-cache

no ip mroute-cache

interface Vlan4

ip address 10.2.1.252 255.255.255.0

no ip route-cache

no ip mroute-cache

interface Vlan5

ip address 10.2.9.252 255.255.255.0

no ip route-cache

no ip mroute-cache

router eigrp 1

network 10.0.0.0

network 172.16.0.0

network 192.168.1.0

!

ip classless

ip http server

ip http authentication local

ip http secure-server

!

!

control-plane

Re: Routing Problem

hi

In your linux box instead of having 2 sets of routes thru the NICS with equal metric can you add/mention up some metric for the second set thru which is pointed via the secondary interface ?

Also once you make the link down can you try tracing from both the ends (from your pc as well as from your linux box) so that you can find out where the trace is getting stucked up..

regds

Re: Routing Problem

HI,

metric supports in windows, even in linux the commands accepts, but doesn't work out in linux, where as in windows it perfects work out, any how i hav solved this issue using routing policy in linux.thanks

229
Views
0
Helpful
4
Replies