Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Routing problems with ADSL & 2610 router

I have up graded a 2610 router with 2 x ADSL Wic's.

When the router is configured the connection to the Internet opens & I can ping internet address from the router.

The PC connected (via crossed over cable) can ping the router ports (lan & wan) but not any Internet address.

See attached config.

Smart Init is enabled

smart init is sizing iomem

ID MEMORY_REQ TYPE

000091 0X0008B800 C2600 single Ethernet

0X000F3BB0 public buffer pools

0X00211000 public particle pools

TOTAL: 0X003903B0

If any of the above Memory Requirements are

"UNKNOWN", you may be using an unsupported

configuration or there is a software problem and

system operation may be compromised.

Rounded IOMEM up to: 4Mb.

Using 6 percent iomem. [4Mb/64Mb]

Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(11)T1, RELEASE SOFTWARE (fc2

)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 29-Sep-02 21:46 by ccai

Image text-base: 0x8000809C, data-base: 0x8166E55C

cisco 2610 (MPC860) processor (revision 0x203) with 61440K/4096K bytes of memory

.

Processor board ID JAD04525MZ7 (2077339766)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

2 ATM network interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Press RETURN to get started!

*Mar 1 00:00:19.467: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up

*Mar 1 00:00:19.467: %LINK-3-UPDOWN: Interface ATM0/0, changed state to down

*Mar 1 00:00:19.467: %LINK-3-UPDOWN: Interface ATM0/1, changed state to down

*Mar 1 00:00:20.669: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/

0, changed state to up

*Mar 1 00:00:20.669: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, ch

anged state to down

*Mar 1 00:00:20.669: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/1, ch

anged state to down

*Mar 1 00:00:21.486: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC created.

*Mar 1 00:00:23.774: %SYS-5-CONFIG_I: Configured from memory by console

*Mar 1 00:00:24.275: %LINK-5-CHANGED: Interface ATM0/1, changed state to admini

stratively down

*Mar 1 00:00:27.184: %SYS-5-RESTART: System restarted --

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(11)T1, RELEASE SOFTWARE (fc2

)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 29-Sep-02 21:46 by ccai

*Mar 1 00:00:27.184: %SNMP-5-COLDSTART: SNMP agent on host Hjlyons.com is under

going a cold start

*Mar 1 00:00:28.189: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/

0, changed state to down

Hjlyons.com>

Hjlyons.com>

Hjlyons.com>en

Password:

Hjlyons.com#sh run

Building configuration...

Current configuration : 1310 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

xxxxxxx (moderator edit)

!

ip subnet-zero

!

!

ip name-server 159.134.237.6

ip name-server 159.134.248.17

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

!

!

!

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

bundle-enable

dsl operating-mode auto

!

interface Ethernet0/0

ip address 213.190.154.25 255.255.255.248

ip tcp adjust-mss 1452

half-duplex

!

interface ATM0/1

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname username

ppp chap password 0 password

ppp pap sent-username username password 0 password

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

!

!

dialer-list 1 protocol ip permit

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

password password

login

!

!

end

Regards,

Tony

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Routing problems with ADSL & 2610 router

Having already verified that your Internet connection is good with a ping from the router, the next step would be to do an extended ping from the Ethernet0/0 interface. My guess is that you can't. Your using a public IP address on the ethernet side, but your ISP may not be routing it to you.

You have two options if that's the case. If your IP addresses are actually registered with your ISP, get them to set up routing properly. If they are not actually registered, or you simply want to hide your LAN behind the router (prefered) you can set up PAT.

On the E0/0 - ip nat inside

ON THE Dialer1 - ip nat outside

from global config - access-list 1 permit 213.190.154.24 255.255.255.248

from global config - ip nat inside source list 1 interface Dialer1 overload

8 REPLIES
New Member

Re: Routing problems with ADSL & 2610 router

Having already verified that your Internet connection is good with a ping from the router, the next step would be to do an extended ping from the Ethernet0/0 interface. My guess is that you can't. Your using a public IP address on the ethernet side, but your ISP may not be routing it to you.

You have two options if that's the case. If your IP addresses are actually registered with your ISP, get them to set up routing properly. If they are not actually registered, or you simply want to hide your LAN behind the router (prefered) you can set up PAT.

On the E0/0 - ip nat inside

ON THE Dialer1 - ip nat outside

from global config - access-list 1 permit 213.190.154.24 255.255.255.248

from global config - ip nat inside source list 1 interface Dialer1 overload

New Member

Re: Routing problems with ADSL & 2610 router

Tony, if you find what the problem might be, please let me know. I am running into the same exact problem with my setup. I have the identical setup, except with only one ADSL-WIC. I think you will find that if you do "NAT" on your Dialer interface, then everything will work ok. If you are like me and need to use a static IP address, then there is no access. Like you, I am able to ping addresses on the internet, but not able to get access through from my LAN. I worked with Cisco a bit on this and the engineer believed that my configuration is correct, and the problem might be with my local provider (BellSouth) not having my IP address assignments routed correctly. I have contacted Bellsouth, and am still waiting to here back from them. They usually aren't the fastest in getting a response back. If you discover anything, please let me know at David_Coleman@dayintl.com. If I find anything, I'll be sure to let you know.

New Member

Re: Routing problems with ADSL & 2610 router

Tony, I seemed to have resolved my problems with BellSouth. I happened across a small blurb on their support website about appending "%static" on my username for login. I called their tech support and confirmed. I made the change and everything seems to work as it should. I'm not sure what ISP you are using but you might check to make sure that your login is correct. BellSouth told me that until my login was correct, my ip addresses would not be available and routed for me to use. My username now looks like "username%static".

New Member

Re: Routing problems with ADSL & 2610 router

David,

My problem was not using nat, and i had the static ip addressing from the second account in use with wrong username & password.

Thank you for your help David & Bob.

Tony

New Member

Re: Routing problems with ADSL & 2610 router

Hello Tony,

I was just wondering how good your connection is with 2 ADSL lines? I noticed that you are using Eircom as am I. We just got connected with a 2621 and 1 ADSL line. I was disappointed with it (especially playing games online...clanradox ping is crap now)so I was considering going with another line through the same router. We are coming from a 512K IP line with Esat, and it seems a bit faster and infinetly more stable. Don't ask me why.

How many PC's do you have on your lan?

Tnks

Chris

New Member

Re: Routing problems with ADSL & 2610 router

Chris,

I'am setting this up for another company, the idea is one ADSL line for mail and the second one for Surfing etc. Eircom up to a couple of weeks a did not support multi-linking of ADSL lines. The speed issue is a result of the contention ratio, if you check it with http://www.modemspeedtest.com/ a couple of times during the day you will find big differences.

Regards,

Tony

New Member

Re: Routing problems with ADSL & 2610 router

I was hoping that the connection would be faster than our 512K IP line. I'm still not sure why our IP line is actually faster than the 1MG ADSL line even with twice the PC's hooked up to the IP line. I'm still wondering if there is a configuration issue on my router possibly. Do you think that a multiple line might take care of the latency issue?

New Member

Re: Routing problems with ADSL & 2610 router

You might be experiencing a traffic contention issue with your ADSL provider.

Your local ADSL link does offer high speed access, but it connects to a local ADSL Mux, along with many other ADSL users.

The provider then gives a shared uplink for all users on the mux.

With leased line you have 100% of the bandwidth you pay for, so it can be faster.

This contention on ADSL can be 20:1 and higher........the hidden cost of cheaper bandwidth!

231
Views
0
Helpful
8
Replies
CreatePlease to create content