Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Routing Question with two LANs

I have a spare 2621 sitting on my desk and i would like to run a little experiment.

Im a little new to this, so hopefully this makes sense.

Lets say i had two LAN segments that are seperated right now, but would like to stick this router between them and route traffic between them?

Can anyone help me with a config for this? Here is what i have right now:

If you need further information/explaination please ask.

Thank You!

-t

Current configuration : 1221 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2621

!

logging buffered 4096 debugging

logging console emergencies

enable secret 5 ************

enable password ********

!

memory-size iomem 10

ip subnet-zero

ip cef

!

!

ip tcp path-mtu-discovery

no ip domain-lookup

!

no call rsvp-sync

!

!

interface FastEthernet0/0

description Network1

ip address 10.1.1.100 255.255.0.0

ip directed-broadcast

ip nat inside

load-interval 30

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1

description Network2

ip address 10.10.1.1 255.255.0.0

ip directed-broadcast

ip nat outside

load-interval 30

speed 100

full-duplex

no cdp enable

!

ip classless

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

no ip http server

!

logging trap emergencies

logging 10.1.1.5

access-list 1 permit 10.1.0.0 0.0.255.255

dialer-list 1 protocol ip permit

no cdp run

!

dial-peer cor custom

!

!

!

banner motd ^C^C

!

line con 0

exec-timeout 0 0

password ********

login

line aux 0

line vty 0 4

password ********

login

!

end

  • Other Network Infrastructure Subjects
5 REPLIES
Hall of Fame Super Silver

Re: Routing Question with two LANs

Mark

I am not quite clear what your question is and therefore not clear how much detail is appropriate in the answer. If you have a segment with subnet 10.1.0.0 255.255.0.0 and a segmnt with subnet 10.10.0.0 255.255.0.0 this config will route traffic between them ok.

Beyond that there are a couple of aspects of the config that I am not sure why they are there, such as :

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

Also I am not sure why there is a default route. I am not sure why you have a dialer-list configured when you have no dialer interface configured.

Also configuration of ip directed-broadcast is a bit unusual, though I would not say that it was necessarily a problem. Is there some reason that it is configured this way?

HTH

Rick

New Member

Re: Routing Question with two LANs

Hopefully this explaination helps.

We are a manufacturing company, and not sure if you have ever dealt with A/B or Rockwell Controls guys, but they seem to run things in a whole different world than us IT folks. And now as more and more control, I/O devices are getting slapped into the ethernet world, companies like mine are starting to see a change where their corporate environment is extending right down to the shop floor with equipment that is making our company run. (we have close to 150 nodes out on the floor now)

This is all fine and dandy, but there needs to be some protection of us against them and them against us. (I dont want to create sides, but with this you have to treat them as two completely different entities that just have a pipe between them that will allow certain connections and traffic to flow freely between both). I have had the whole corporate network taken down because of problems on the mfg side of things, engineers freely plugging things into the network and down it goes...long story.

So what my thoughts are, being a cisco/routing novice, and since i have access to this 2621 router for the next few weeks, is run some tests. Set up a scenario where this router acts as a middle man and can route between two independant LANs.

Thanks for the help. perhaps you can offer some further suggestions.

Hall of Fame Super Silver

Re: Routing Question with two LANs

Mark

I certainly understand the need to separate parts of the network and to treat them as separate entities. I agree that putting a router between the segments is a good way to achieve this.

As I said in my previous post I believe that you have the basic concept of configuring each segment on an interface and routing between the segments. I am guessing that the router that you are experimenting on had been previously used for some other purpose and that you have put your two subnets into an existing config. I believe that there are several parts of that config which just confuse what you are trying to understand (and I pointed some of them out in my previous post). My suggestion is that you clear the config and start over again with a fresh start. Get to privilege mode; issue the command clear startup-config; issue the command reload and confirm the reload (if it prompts you about saving the existing config say no); when the router has booted you will have a fresh start for your experiment.

HTH

Rick

New Member

Re: Routing Question with two LANs

Rick-

sorry, i guess i forgot to answer the questions you posed before. Yes this router was used for something previously, it was our voice router, which was replaced about a month ago.

I will clear the config and start over, thanks

-m

New Member

Re: Routing Question with two LANs

Mark,

I am in the same situation as you are. What is your solution? Any suggestion that you may advice?

Thanks,

342
Views
0
Helpful
5
Replies
This widget could not be displayed.