Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Routing two subnets throught cisco 2500 router

My Current configuration is as follows:

Using 1492 out of 32762 bytes

!

! Last configuration change at 12:07:26 pst Mon May 13 2002

! NVRAM config last updated at 12:07:29 pst Mon May 13 2002

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

!

ip subnet-zero

ip nat inside source list 1 interface Serial0 overload

ip nat inside source static 10.13.1.62 208.x.x.x

ip nat inside source static 10.13.1.131 208.x.x.x

ip nat inside source static 10.13.1.64 208.x.x.x

no ip domain-lookup

clock timezone pst -8

!

!

interface Ethernet0

ip address 10.13.1.130 255.255.255.0

no ip directed-broadcast

ip nat inside

no ip route-cache

no ip mroute-cache

!

interface Serial0

ip address 208.x.x.x 255.255.255.224

no ip directed-broadcast

ip nat outside

no ip route-cache

no ip mroute-cache

bandwidth 1536

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

router rip

version 2

redistribute connected

network 208.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 208.x.x.x 255.255.255.224 Serial0

!

no logging console

no logging monitor

access-list 1 permit 10.13.1.0 0.0.0.255

!

What I need to do is also send 192 subnet through the router. How do I configure that?

4 REPLIES
Cisco Employee

Re: Routing two subnets throught cisco 2500 router

We probably need a little more information here but I am going to take a guess here. If I am totally off the track then let me know. I am going with the assumption that you want to configure th private 192.x.x.x ip subnet on your ethernet segment and then allow the 192.x segment to be routed out to the internet like your private 10.x subnet. If this is the case, then you would need to configure a secondary ip address on your ethernet 0 interface.

*VERY IMPORTANT* don't forget the keyword 'secondary' at the end of the ip address or else your 10.x ip address will be overwritten by 192.x address. Since your 192 is also a private ip address therefore you will have to run the network address translation (NAT) commands to bind your private 192 address to the public addresses, following the same guidleines as you did for the 10.x network.

Community Member

Re: Routing two subnets throught cisco 2500 router

Your assumption is correct. Is there any examples I can work with?

Cisco Employee

Re: Routing two subnets throught cisco 2500 router

For Network Address Translation see:

http://www.cisco.com/warp/public/556/12.html

For assigning secondary ip addres just go to the interface ethernet0 in config mode and assign the ip address with the appropriate mask and add the word "secondary" at the end to avoid overwriting the 10.x ip address. see: http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c/ipcprt1/1cdipadr.htm#xtocid221563

your rest of the configuration should still hold good.

Community Member

Re: Routing two subnets throught cisco 2500 router

You have been very helpful and I think we are almost done. Once again here is the confiuration and what I am looking for.

This is two different networks.

192 Subnet

DSL---Firewall----SWITCH---Local Director-----SWITCH-----SUN Server

10 subnet

T1 Router---Firewall----Switch---Servers

What I want to do is to eliminate the DSL connection and go through the 10 subnet router.

Thank you for all your help.

-Tony

263
Views
0
Helpful
4
Replies
CreatePlease to create content