Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

routing vlanswith 2950 and 2621

I am currently trying to route vlan1 and vlan2 of a 2950 through a 2621. the 2950 is running ios 12.0(5.3)ws1 and the 2621 is running (c2600-js-m)12.1(9a).The native vlan on both devices is vlan1 and I'm using 802.1q, as that's the only encapsulation that the 2950 supports. The subinterfaces of fe0/0 for the 2621 sh up up, the same holds true for fe0/25 of the 2950. when I do "show cdp nei" I can see the other end.

I can also do a directed ping from one sub-interface to the other, on the 2621. I can not how ever ping across. Am I missing something?

5 REPLIES
Cisco Employee

Re: routing vlanswith 2950 and 2621

Can you paste the interface configuration from both the 2950 and the 2621? Also refer to the following page to see if your configuration is correct

http://www.cisco.com/warp/public/473/43.html

New Member

Re: routing vlanswith 2950 and 2621

Here is the config of both devices.

4 ISDN Basic Rate interface(s)

--More--

unix_test01#sh run

Building configuration...

Current configuration : 1063 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname unix_test01

!

enable secret 5 $1$ERUa$8zwFpm3GyrQHGpBri6wlp/

!

!

!

!

!

ip subnet-zero

!

!

!

!

!

!

--More-- interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1

ip address 147.141.5.250 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 147.141.6.250 255.255.255.0

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

--More-- !

interface BRI1/0

no ip address

shutdown

isdn x25 static-tei 0

!

interface BRI1/1

no ip address

shutdown

isdn x25 static-tei 0

!

interface BRI1/2

no ip address

shutdown

isdn x25 static-tei 0

!

interface BRI1/3

no ip address

shutdown

isdn x25 static-tei 0

!

ip classless

ip http server

--More-- !

!

!

line con 0

exec-timeout 0 0

password frame

login

line aux 0

password frame

login

line vty 0 4

password frame

login

!

no scheduler allocate

end

unix_test01#

sh run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname sw2ip33_test

!

enable secret 5 $1$NCzP$lpY.4UTeOAleCcUtBz1qv.

!

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

--More-- !

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

--More-- interface FastEthernet0/13

switchport access vlan 2

!

interface FastEthernet0/14

switchport access vlan 2

!

interface FastEthernet0/15

switchport access vlan 2

!

interface FastEthernet0/16

switchport access vlan 2

!

interface FastEthernet0/17

switchport access vlan 2

!

interface FastEthernet0/18

switchport access vlan 2

!

interface FastEthernet0/19

switchport access vlan 2

!

interface FastEthernet0/20

switchport access vlan 2

--More-- !

interface FastEthernet0/21

switchport access vlan 2

!

interface FastEthernet0/22

switchport access vlan 2

!

interface FastEthernet0/23

switchport access vlan 2

!

interface FastEthernet0/24

switchport access vlan 2

!

interface FastEthernet0/25

switchport mode trunk

!

interface FastEthernet0/26

!

interface VLAN1

ip address 147.141.5.240 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

--More-- ip default-gateway 147.141.5.250

!

line con 0

password frame

login

transport input none

stopbits 1

line vty 0 4

password frame

login

line vty 5 15

password frame

login

!

end

sw2ip33_test#

Thanx

LB

Cisco Employee

Re: routing vlanswith 2950 and 2621

Try using "native" keyword

interface FastEthernet0/0.1

encapsulation dot1Q 1 native <<<<<<<<--------

ip address 147.141.5.250 255.255.255.0

My bad..I pointed you to a wrong URL earlier

http://www.cisco.com/warp/public/473/50.shtml

New Member

Re: routing vlanswith 2950 and 2621

When I enter fastethernet 0/0.1 and specify dot1q, it doesn't have the option for "native". just CR>

New Member

Re: routing vlanswith 2950 and 2621

I beleive I have corrected the problem, albeit, not the way I would have thought. I decided to configure the 2621 fastethernet0/0 the same way you would if I were using ios earlier than 12.1(3)t. I removed sub interface fastethernet 0/0.1 and gave the IP address to fastethernet 0/0. I can now reach both vlans on the 1950. There appears to be a problem using this config with 12.1(9a).

Thanx for the help.

91
Views
0
Helpful
5
Replies
CreatePlease login to create content