Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

routing with 2 eth ports on router and 1s0

I am routing across eth0/0 and eht0/1 to machines on the opposite networks.

my 10.1.0.0 network uses 10.1.0.1 as the internet gateway and this works fine. My problem is that my 10.0.0.0 network cannot get out on the internet. what must i do for the 10.0.0.0 network to allow them to use the internet on this router? Is it the static route that combines the networks together that allows it to use the default gateway? if so how do i assign this static route. If the two networks are routing why doesn't know to use the default gatway of 10.1.0.1 . I know there are two different subnets but if it routing what makes the 10.1.0.1 different from any other 10.1.0.0 address. Why does it not just use the same gateway 10.1.0.1. Here is my config for convienence.

version 12.1

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname freshbeg

!

enable password !

!

!

!

!

ip subnet-zero

ip name-server 204.70.127.127

!

!

!

!

interface FastEthernet0/0

description connected to fresh beginnings internal network

ip address 10.1.0.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface Serial0/0

description connected to Cable and Wireless Network

ip address 208.173.23.82 255.255.255.252

ip nat outside

service-module t1 remote-alarm-enable

!

interface FastEthernet0/1

ip address 10.0.0.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

router rip

passive-interface Serial0/0

network 10.0.0.0

no auto-summary

!

ip nat inside source list 1 interface Serial0/0 overload

ip nat inside source static 10.1.0.155 208.

ip nat inside source static 10.1.0.58 208.

ip nat inside source static 10.1.0.34 208.

ip route 0.0.0.0 0.0.0.0 Serial0/0

ip http server

!

access-list 1 permit 10.1.0.0 0.0.0.255

access-list 1 permit 10.1.1.0 0.0.0.255

access-list 2 permit 10.0.0.0 0.0.0.255

snmp-server engineID local

snmp-server community public view v1default RO

snmp-server community ecofl RO

snmp-server community RO

snmp-server packetsize 2048

snmp-server location Valdosta, Ga

snmp-server contact Phillip Guthrie ,229.242.0237 ext 263,phillip@eleadtrack.ne

snmp-server enable traps snmp

snmp-server host 10.1.0.34 public

!

line con 0

exec-timeout 0 0

password

login

transport preferred none

transport input none

line aux 0

login

modem InOut

transport preferred none

transport input all

transport output pad v120 telnet rlogin udptn

flowcontrol hardware

line vty 0 4

password

login

transport preferred none

!

end

Thanks for all that has been helping on this issue.

phillip

1 ACCEPTED SOLUTION

Accepted Solutions

Re: routing with 2 eth ports on router and 1s0

It is a NAT issue. Your access-list 1 only permits 10.1.0.0 and 10.1.1.0. You gave 10.0.0.0 a different acl (2). Add 10.0.0.0 to access-list 1 and you should be fine.

Steve

2 REPLIES

Re: routing with 2 eth ports on router and 1s0

It is a NAT issue. Your access-list 1 only permits 10.1.0.0 and 10.1.1.0. You gave 10.0.0.0 a different acl (2). Add 10.0.0.0 to access-list 1 and you should be fine.

Steve

New Member

Re: routing with 2 eth ports on router and 1s0

Steve you were right on man!!! When I grow up i want to be a CCIE like you. Thanks again for your expertise

Phillip.

121
Views
0
Helpful
2
Replies
CreatePlease to create content