Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

routing

hi i have a probléme,

i enabled a rip protocol in a cisco 1720 with 2 eth int,

router rip

network 10.0.0.0

network 192.168.6.0

the probléme is that from the router i can ping every network, but from the pc, if i am in the network 192.168.6.0 for example, i can't rich the network 10.0.0.0;

please why???????

this is a sh ruCurrent configuration : 619 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

enable password cisco

!

memory-size iomem 25

no ip subnet-zero

!

!

!

!

!

!

!

interface Loopback0

ip address xxx.xxx.xxx.13 255.255.255.248

!

--More--

interface Ethernet0

ip address 10.0.0.1 255.0.0.0

half-duplex

!

interface FastEthernet0

ip address xxx.xxx.6.150 255.255.255

speed auto

!

router rip

network 10.0.0.0

network 192.168.6.0

!

ip default-gateway 10.0.0.2

no ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

no scheduler allocate

--More--

!

interface FastEthernet0

ip address xxx.xxx.6.150 255.255.255.0

speed auto

!

router rip

network 10.0.0.0

network 192.168.6.0

!

ip default-gateway 10.0.0.2

no ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

no scheduler allocate

!

end

1 REPLY
Gold

Re: routing

First, I'd kill off "no ip classless." It probably isn't making any difference in this situation, but it might hurt you later.

Beyond this, the first thing to check is the default gateway on the host you're pinging from. If you can ping everything from the router, and you can't get off segment from a host attached to the router, I always suspect the default gateway on the host first. You can actually test the default gateway setting on the host from the router, by pinging an attached host using the loopback address as a source. So:

7206F#ping

Protocol [ip]:

Target IP address: 10.1.1.1

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: loopback 0

....

If the pgin fails, the problem is most likely on the host side. If the ping succeeds, then we would need a show ip route off the router (though I don' see how the routing on a single router could really be messed up all that bad--i've seen two routers fail miserably, but never one). :-)

Russ.W

87
Views
5
Helpful
1
Replies
CreatePlease to create content