Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

sra
New Member

RSH not working

Hello everyone,

I have a Cisco 2610XM running 12.2(12). I am trying to connect to it using rsh from a linux box, and run a command on the router. This is what I have configured:

ip rcmd rcp-enable

ip rcmd rsh-enable

ip rcmd remote-host root 172.16.5.68 root enable

ip rcmd remote-username root

ip rcmd source-interface FastEthernet0/0

From my linux box I just type "rsh <router_ip> show ver" but It's not working. The TCP connection appears to be made but I get no reply. Here is what the router is seeing:

Nov 26 16:58:54 nas 176572: 2w6d: IP: s=172.16.5.68 (FastEthernet0/0), d=172.16.3.16 (FastEthernet0/0), len 60, rcvd 3

Nov 26 16:58:54 nas 176573: 2w6d: TCP src=1022, dst=514, seq=266725646, ack=0, win=5840 SYN

Nov 26 16:58:54 nas 176574: 2w6d: IP: s=172.16.5.68 (FastEthernet0/0), d=172.16.3.16 (FastEthernet0/0), len 40, rcvd 3

Nov 26 16:58:54 nas 176575: 2w6d: TCP src=1022, dst=514, seq=266725647, ack=3830603499, win=5840 ACK

Nov 26 16:58:54 nas 176576: 2w6d: IP: s=172.16.5.68 (FastEthernet0/0), d=172.16.3.16 (FastEthernet0/0), len 45, rcvd 3

Nov 26 16:58:54 nas 176577: 2w6d: TCP src=1022, dst=514, seq=266725647, ack=3830603499, win=5840 ACK PSH

Nov 26 16:58:54 nas 176578: 2w6d: RCMD: [514 <- 172.16.5.68:1022] recv 1021\0

and after a timeout:

Nov 26 16:59:24 nas 176579: 2w6d: RCMD: [1023 -> 172.16.5.68:0] open failed -- Connection timed out; remote host not responding

Nov 26 16:59:24 nas 176580: 2w6d: IP: s=172.16.5.68 (FastEthernet0/0), d=172.16.3.16 (FastEthernet0/0), len 40, rcvd 3

Nov 26 16:59:24 nas 176581: 2w6d: TCP src=1022, dst=514, seq=266725652, ack=3830603500, win=5840 ACK FIN

Very interesting that the same rsh command ran against another router, configured identically, works perfectly. The only difference is the IOS, an older one: 11.3(11a). There is no ACL in place. I have full access to the router but the rsh is not working.

Anyone has any clue of what might be the problem ? Thank you in advance.

Best regards,

Stefan

2 REPLIES
New Member

Re: RSH not working

Stefan,

Try using "rsh" with "-l root" option. With this, you are basically specifying the password for the user "root" on the router.

Good luck.

--Murali

sra
New Member

Re: RSH not working

Hello,

It does not work. On the other router on either cases: rsh -l root or just plain rsh. But on this router, it's not working at all :(

Stefan

295
Views
0
Helpful
2
Replies