Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RSPAN What am I missing here ?

Hi everybody

I am trying to set up the simplest RSPAN configuration possible:

Cat2950C ---trunk link on G0/1----Cat2950

I can see the port 1 (the reflector port on Cat 2) blinking but a sniffer

connected to port

F0/24 on Cat2 is not seeing any traffic (excepting some broadcasts ).

Please see the below listed configs and let me know if you have any idea

what could be wrong here.

Thank you

Cat1 has source ports F0/23 and F0/24 and reflector port F0/1

Cat2 has destination port F0/24

Cat1 VTP mode= server

Cat2 VTP mode= client

Prunning disabled

Vlan 1 = default vlan

Vlan 2 = F0/23 and F0/24 are assigned to this vlan

Vlan 3 - Rspan vlan (configured accordingly with rspan option)

VLAN ISL Id: 1

Name: default

Media Type: Ethernet

VLAN 802.10 Id: 100001

State: Operational

MTU: 1500

Backup CRF Mode: Disabled

Remote SPAN VLAN: No

VLAN ISL Id: 2

Name: Source

Media Type: Ethernet

VLAN 802.10 Id: 100002

State: Operational

MTU: 1500

Backup CRF Mode: Disabled

Remote SPAN VLAN: No

VLAN ISL Id: 3

Name: Sniffer

Media Type: Ethernet

VLAN 802.10 Id: 100003

State: Operational

MTU: 1500

Backup CRF Mode: Disabled

Remote SPAN VLAN: Yes

-----------------------------------Config Cat

1----------------------------------------------

!

version 12.1

!

hostname Cat1

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface range FastEthernet0/1 - 22

no ip address

duplex full

speed 100

no snmp trap link-status

interface FastEthernet0/23

no ip address

duplex full

speed 100

switchport access vlan 2

no snmp trap link-status

interface FastEthernet0/24

no ip address

duplex full

speed 100

switchport access vlan 2

no snmp trap link-status

!

interface GigabitEthernet0/1

description Uplink26

switchport mode trunk

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 10.100.25.113 255.255.255.0

no ip route-cache

!

ip default-gateway 10.100.25.254

ip http server

!

monitor session 1 source interface Fa0/23 - 24

monitor session 1 destination remote vlan 3 reflector-port Fa0/1

end

Switch14#

-----------------------------------Config Cat

2----------------------------------------------

!

version 12.1

!

hostname Cat2

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface range FastEthernet0/1 - 24

no ip address

duplex full

speed 100

no snmp trap link-status

interface GigabitEthernet0/1

description Uplink26

switchport mode trunk

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 10.100.25.114 255.255.255.0

no ip route-cache

!

ip default-gateway 10.100.25.254

ip http server

!

!

!

monitor session 1 destination interface F0/24

monitor session 1 destination remote vlan 3

end

5 REPLIES
New Member

Re: RSPAN What am I missing here ?

I made a mistake. Please read

"the reflector port on Cat 1" instead of

"the reflector port on Cat 2"

Sorry for that and

Thank you in advance

Cristian

Bronze

Re: RSPAN What am I missing here ?

is this a typo ?

monitor session 1 destination interface F0/24

monitor session 1 destination remote vlan 3

Should be:

monitor session 1 SOURCE remote vlan 3

New Member

Re: RSPAN What am I missing here ?

Yeah that was a typo.

Somebody on an other discussion group already noticed that. Sorry for that. It was a cut paste and edit...:-(

Is everythig ok with this config ?

Bronze

Re: RSPAN What am I missing here ?

looks okay. sure vlan 3 is active on both switches and is been carried across the trunk ?

New Member

Re: RSPAN What am I missing here ?

Yes it is. As I mentioned before one of the switches is in VTP mode = server and the other is in client mode. I created all the vlans (excepting the default) using the first switch.

(the server).

Is there any way I can debug this feature ?

Thank you

141
Views
0
Helpful
5
Replies
CreatePlease to create content