Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

secondary address and router lockup.

Just wondering if anyone has had this problem as well, but I have a wan setup where a router at a spoke site intermitantly locks up.

The only thing which seems to point to a problem with the secondary address is that routing between two subnets on the local site (spoke) are also affected during the fault. I am looking at changing this config to subinterfaces instead of the secondary addresses but would like a second option.

Here is the relevant extract from the current config.

sh run

Building configuration...

Current configuration : 2983 bytes

!

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

no service password-encryption

!

hostname xxx

!

logging buffered 10000 debugging

!

clock timezone GMT 0

clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 1:00

ip subnet-zero

!

!

no ip domain-lookup

!

call rsvp-sync

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

no ip split-horizon eigrp 100

duplex auto

speed auto

!

interface FastEthernet0/0.1101

encapsulation dot1Q 1101

ip address 172.16.31.6 255.255.255.252

no ip redirects

!

interface FastEthernet0/0.1111

encapsulation dot1Q 1111

ip address 172.16.32.6 255.255.255.252

--More-- no ip redirects

!

interface FastEthernet0/1

ip address 192.1.13.100 255.255.255.0 secondary

ip address 192.1.3.15 255.255.255.0

speed auto

half-duplex

!

router eigrp 100

redistribute connected

redistribute static

network 172.16.31.4 0.0.0.3

network 172.16.32.4 0.0.0.3

network 192.1.3.0

network 192.1.13.0

no auto-summary

!

ip classless

ip route 192.1.2.0 255.255.255.0 192.1.2.57

ip route 192.1.6.0 255.255.255.0 192.1.3.236

ip route 192.1.7.0 255.255.255.0 192.1.3.211

ip route 192.1.8.0 255.255.255.0 192.1.2.57

ip route 192.1.9.0 255.255.255.0 192.1.3.1

!

logging 192.1.3.166

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

no snmp-server enable traps tty

snmp-server enable traps isdn call-information

snmp-server enable traps hsrp

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps envmon

snmp-server enable traps syslog

!

dial-peer cor custom

!

====================================================

version details are;

sh vers

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(21a), RELEASE SOFTWARE (fc2)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Fri 09-Jan-04 19:40 by kellmill

Image text-base: 0x8000808C, data-base: 0x81116ADC

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

xxx uptime is 6 hours, 30 minutes

System returned to ROM by power-on

System image file is "flash:c2600-is-mz.122-21a.bin"

cisco 2621XM (MPC860P) processor (revision 0x100) with 93184K/5120K bytes of memory.

Processor board ID xxx

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Please help.

Regards,

Adrian.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: secondary address and router lockup.

You could potentially have all 4 ethernet segments on the same interface if you used dot1q trunking like you did for the first 2 subinterfaces... I wouldn't think that having the secondary IP address should be causing any problems though.

Personally I would nail the FastE's at 100/full if possible. Running them as "auto/auto" or "auto/half" isn't a good idea. I know that dot1q trunking off a router doesn't work very well on 10/half and I bet it would have some of the same problems with 100/half too. So I would recommend putting them on 100/full if possible...

1 REPLY

Re: secondary address and router lockup.

You could potentially have all 4 ethernet segments on the same interface if you used dot1q trunking like you did for the first 2 subinterfaces... I wouldn't think that having the secondary IP address should be causing any problems though.

Personally I would nail the FastE's at 100/full if possible. Running them as "auto/auto" or "auto/half" isn't a good idea. I know that dot1q trunking off a router doesn't work very well on 10/half and I bet it would have some of the same problems with 100/half too. So I would recommend putting them on 100/full if possible...

260
Views
0
Helpful
1
Replies