Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Secondary addresses

I am in the procces of configuring a 7206 for the migration of our DSL customers from another router. Several of our customers are set up in bridged mode. When trying to create the bridge group I get the following error:

c7206(config)#bridge 1 protocol ieee

c7206(config)#bridge 1 route ip

c7206(config)#int bvi1

c7206(config-if)#ip address 207.149.25.185 255.255.255.248

207.149.25.184 overlaps with secondary address on FastEthernet0/0

The address configured on the fastethernet interface is 207.149.25.1 255.255.255.0 and is used by some DSL customers with staticly assigned IP addresses as their default gateway.

My question is, is it neccessary to set up a secondary address for every network we route? Internaly we use OSPF, externally BGP.

I suppose I could set up a subnet for these customers and assign a subnet mask and default gateway accordingly and reassign addresses.

Thanks

7 REPLIES
Silver

Re: Secondary addresses

This error simply means that you need a unique IP address on L3 interfaces on your router. 207.149.25.1 255.255.255.0 is on the same network as 207.149.25.185 255.255.255.248 so is therefore not valid.

You do not need secondaries to route with OSPF or BGP. Networks put into the routing protocols are based on network statements and types of redistribution.

Hope this helps,

Don

New Member

Re: Secondary addresses

So if I have network statements in BGP and OSPF I do not need to have secondary addresses on the fastethernet interface? How will routes to DSL customers be learned? They will be connecting through a DS3 on an ATM interface on this router.

router ospf 201

redistribute static subnets

network 64.240.108.0 0.0.0.255 area 0

network 64.240.109.0 0.0.0.255 area 0

network 199.217.73.0 0.0.0.255 area 0

network 206.129.12.0 0.0.0.255 area 0

network 206.129.13.0 0.0.0.255 area 0

network 206.129.32.0 0.0.0.255 area 0

network 207.138.224.0 0.0.0.255 area 0

network 207.138.233.0 0.0.0.255 area 0

network 207.149.25.0 0.0.0.255 area 0

network 209.102.32.0 0.0.0.255 area 0

network 209.102.33.0 0.0.0.255 area 0

router bgp 13853

no synchronization

bgp router-id 64.240.108.1

bgp cluster-id 3481985278

network 64.240.108.0 mask 255.255.255.0

network 64.240.109.0 mask 255.255.255.0

network 199.217.73.0

network 206.129.12.0

network 206.129.13.0

network 206.129.32.0

network 207.138.224.0

network 207.138.233.0

network 207.149.12.0

network 207.149.13.0

network 209.102.32.0

network 209.102.33.0

Thanks

Silver

Re: Secondary addresses

The only reason you need secondaries on an interface is to facilitate more hosts off of a specific connected interface for your customers. As long as these networks are put into your routing protocols these networks will be distributed to other peering routers. If this does not answer your question I guess I don't understand what you are after.

Hope this is what you were after,

Don

New Member

Re: Secondary addresses

If a DSL customer is assigned a static IP, a subnet mask and default gateway must also be defined. Currently the default gateway is the.1 and their subnet mask is 255.255.255.0, unfortunatly this is the situation I was handed. So If I remove the .1 address these customers will not have a default gateway, and I assume they must have a default gateway in the same network as their address. It seems to me the only solution is to configure a subnet for these customers and set up a secondary on the router and reassign IP's, net mask and gateway.

Thanks

Silver

Re: Secondary addresses

You are correct. Either secondaries or extending the network that is already there. Placing these networks into your routing protocols will ensure they get propogated.

I guess I did not see what you were asking or this would have been answered several messages ago. Sorry for the confusion.

Hope this helps,

Don

New Member

Re: Secondary addresses

Thanks for your help Don. I just have to work this out to try and affect as few customers as possible.

New Member

Re: Secondary addresses

Dear Mitchel,

All the internet traffic is based on IP addresses.So it is necessary to assign particular IP address on your router port ( wether FErhernet or serial port).

It is ok that u might have your own AS Number and public IP addresses with you.But in case of your customers you must assign an IP address ,if it is a bridge base link.Just assign so many secondary IP address on your router fastethernet port as you need.

I suppose there is no need to create a bridge group.With QoS your router supports it as well.

Secondary you have to set the default route on your router for every subnet .And at your customer end your default route will be the IP address of your FE port accordingely the subnet of that customer.

Kindly see some configuration example as follows:

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.248 secondary

ip address 192.168.10.9 255.255.255.248 secondary

ip address 192.168.10.129 255.255.255.224

rate-limit input access-group 170 64000 8000 9000 conform-action transmit excee

d-action drop

rate-limit input access-group 171 64000 8000 9000 conform-action transmit excee

d-action drop

rate-limit output access-group 170 64000 8000 9000 conform-action transmit exce

ed-action drop

rate-limit output access-group 171 64000 8000 8000 conform-action transmit exce

ed-action drop

ip ospf cost 100

ip ospf priority 20

half-duplex

ip classless

ip route 0.0.0.0 0.0.0.0 Serial1/0

ip route 192.168.10.0 255.255.255.248 FastEthernet0/0

ip route 192.168.10.8 255.255.255.248 FastEthernet0/0

You can also control the bandwidth with creating the access list of particular subnet and put this rate-limit on access list on your router FE port.

It will also control your bandwidth for particular customer.

Again there is no need to set the static IP route for your customer subnet .But if u want better efficiency you can set static route as above.For more customers , you can connect your router & bridge port into layer 2 switch so that you can utilize your router FE port more and more (If there are so many saperate bridge to be connect for different customer).

Hope it will work in your case.

Thanks

Bye

Abhishek Mittal

137
Views
0
Helpful
7
Replies