Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

seperate voice & data vlans

Hi,

I am having an annoying issue that I know there is a simple reason for but I cannot see it.

I want seperate vlans for voice and data on a NSM-ESW-16 switch on a 2811 ISR. I have entered my config as below and the switchport is in trunking mode. However there is no connectivity for the data LAN 192.168.69.254 from a laptop connected the the IP phone in the voice vlan2. Config is below.

ip dhcp pool phone5001

host 192.168.67.1 255.255.255.0

client-identifier 0100.13c3.ef0f.be

default-router 192.168.67.254

option 150 ip 192.168.67.254

DHCP for the Data LAN is via a DHCP Server on the network, no ip address is being assigned to the laptop

interface FastEthernet1/8

switchport access vlan 2

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 2

interface Vlan1

description $FW_INSIDE$

ip address 192.168.69.254 255.255.255.0

ip access-group 100 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

!

interface Vlan2

ip address 192.168.67.254 255.255.255.0

ip access-group 100 in

!

3 REPLIES
Silver

Re: seperate voice & data vlans

Start with removing

"switchport trunk native vlan 2

switchport mode trunk"

and change

"switchport access vlan 2"

on your Fa1/8 interface.

Why are you using VLAN 2 as the native VLAN?

New Member

Re: seperate voice & data vlans

Pure frustration and trying different things to get it working!

I had originally setup as per above, but I want the PC attached to the phone to be on vlan1. There is no connectivty to the Data Vlan1 (pings etc). Am I missing something?

Bronze

Re: seperate voice & data vlans

interface FastEthernet1/8

switchport voice vlan 2

I believe this is all you need. The data would be carried on VLAN 1 and the voice would be on vlan 2.

219
Views
0
Helpful
3
Replies
CreatePlease to create content