Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

serial1 line is up , protocal is down

I using cisco2511 on both side ( head office & branch ). Connecting Leaseline via DSU. They can't connect to each other ( try by ping on the router to another router side ) . I have a problem about serial interface,protocal is down ( down on both side ).

encapsulation : ppp ( both )

head : 192.168.2.1/30

branch : 192.168.2.2/30

=============================================

Serial1 is up, line protocol is down

Hardware is HD64570

Description: connected to Microsys

Internet address is 192.168.2.1/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set, keepalive set (10 sec)

LCP Listen

Closed: IPCP, CDPCP

Last input never, output 00:00:26, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

37 packets output, 2409 bytes, 0 underruns

0 output errors, 0 collisions, 10 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

=============================================

i've try to use encap hdlc on both side , it's still protocal down too.

i contact to link provider for check the line and signal, they've check and said that nothing wrong about the line and signal.

I try to test local loop ( push CSU "local" button ), protocal is up (looped).

I try to test remote loop ( push CSU "remote" button ), protocal is up (looped).

But when i turn off loop test, protocal is down again.

please help me how to correct this ?

13 REPLIES
Silver

Re: serial1 line is up , protocal is down

can you paste in a sh ver

Bronze

Re: serial1 line is up , protocal is down

could be a clocking issue. Does sho cdp see anything? Can you get a show int from the other side?

New Member

Re: serial1 line is up , protocal is down

Can you do a show controllers s1 for both sides if they are both on the same serial interface. Then in the output about a 1/4 way down make sure you see cable connected. Then at the bottom is your line information for XTR and Rec.

New Member

Re: serial1 line is up , protocal is down

First, I am assuming that the service provider is the clock source in which case you will have to set your DSU to receive the clocking signals. What kind of DSU do you have? If it is a Kentrox DataSmart DSU select clock source to "loop".

Also ensure that the framing format [usually ESF], line coding [usually B8ZS] and number of T-1 channels on the DSU are the same on both sides.

Did you try swapping the V.35 cables?

HTH,

Rajesh

New Member

Re: serial1 line is up , protocal is down

Cisco2511#show cdp interface

Ethernet0 is up, line protocol is up

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

Serial0 is administratively down, line protocol is down

Encapsulation HDLC

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

Serial1 is up, line protocol is down

Encapsulation PPP

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

===========================================

Cisco2511#show run

Building configuration...

Current configuration:

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco2511

!

enable password xxxxxx

!

ip subnet-zero

ip nat inside source list 1 interface Serial1 overload

no ip domain-lookup

!

!

!

interface Ethernet0

description connected to EthernetLAN

ip address 192.168.1.10 255.255.255.0

ip nat inside

!

interface Serial0

no ip address

no ip mroute-cache

shutdown

!

interface Serial1

description connected to Microsys

ip address 192.168.2.1 255.255.255.252

ip nat outside

encapsulation ppp

!

interface Async1

no ip address

shutdown

!

interface Async2

no ip address

shutdown

!

interface Async3

no ip address

shutdown

!

interface Async4

no ip address

shutdown

!

interface Async5

no ip address

shutdown

!

interface Async6

no ip address

shutdown

!

interface Async7

no ip address

shutdown

!

interface Async8

no ip address

shutdown

!

interface Async9

no ip address

shutdown

!

interface Async10

no ip address

shutdown

!

interface Async11

no ip address

shutdown

!

interface Async12

no ip address

shutdown

!

interface Async13

no ip address

shutdown

!

interface Async14

no ip address

shutdown

!

interface Async15

no ip address

shutdown

!

interface Async16

no ip address

shutdown

!

router rip

version 2

passive-interface Serial1

network 192.168.1.0

network 192.168.2.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial1

!

access-list 1 permit 192.168.1.0 0.0.0.255

snmp-server community public RO

!

line con 0

exec-timeout 0 0

password xxxx

login

password xxxx

login

!

end

Silver

Re: serial1 line is up , protocal is down

are you sure your serial interface is not an async , some 25xx routers only come with low speed serials and only will support up to 128K, if you exceed the 128K a symptom would be line protocol down, a sh ver will show you this , please paste in a sh ver

New Member

Re: serial1 line is up , protocal is down

Cisco2511#show ver

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-I-L), Version 11.3(9)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Wed 07-Apr-99 15:27 by pwade

Image text-base: 0x0302BB8C, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE

BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)

Cisco2511 uptime is 35 minutes

System restarted by power-on

System image file is "flash:c2500-i-l_113-9_T.bin", booted via flash

cisco 2511 (68030) processor (revision L) with 14336K/2048K bytes of memory.

Processor board ID 06197855, with hardware revision 00000000

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

16 terminal line(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

=========================================

DSU : JNA FlexRate NTU V.35

Silver

Re: serial1 line is up , protocal is down

cool it looks like you are ok with the serial interfaces . What about the other end? what kind of box is there ? If it is a Cisco box when you use hdlc do you get protocol up or down ?

Is there an extended demarc at either end ?

New Member

Re: serial1 line is up , protocal is down

i've another sign of problem.

when i choose "ppp encap" and push "local or remote loop test", then protocal is down.

when i choose "hdlc encap" and push "local or remote loop test", then protocal is up.

is my link provider not support "encap ppp" ?

help pls.

Silver

Re: serial1 line is up , protocal is down

Ok, good,

have you tried s1 yet ? maybe s0 is bad

when you use hdlc can you ping ?

What does the carrier loop the smartjack or the csu's ?

PPP has more overhead than hdlc and is going to be more sensitive to a dirty line. What you can do is change the encap to hdlc so oyu get line and protocol up . Once you have this you can perform loops to isolate the problem .

If you have external CSU give yourself a dte loop on both ends , this will loop your dsu to your serial interface when the line goes up up (looped) ping yourself , you should get all your ping back , if you do not there is a problem between the dsu and the serial int , mostlikey a bad v.35.

if both sides ping good then from the csu a put up a line loop this will loop csu a toward router b , then ping if pings fail then put loopback plug on the smart jack from router b to csu a on router a you should see up up (looped ) if you do not then a problem with the carrier , if you can ping ok then you have a problem between demarc at routerb side and router B

New Member

Re: serial1 line is up , protocal is down

ok , when i change to "hdlc encap", everything is working ( protocal is up , i can ping to another side ). Thanks for your every advise.

I just wonder why "ppp encap" is not work on this case ? Because i have a router ( Zyxel Prestige153x ) which not support "hdlc encap". So if one day i need to use Prestige153x via "ppp encap", it's not work for sure. How do i use "ppp encap" for the future use ?

I mean, right now "hdlc encap" is work fine & "ppp encap" is not work. But I need to use "ppp encap" for the future using. How do I ?

Silver

Re: serial1 line is up , protocal is down

On the remote end is there any authentication configured ? I noticed in your sh int s0 earlier that the LCP is in Listen , this mean it is waiting for a response from the remote end. With PPP all the parameters must match on each end of the link.What does the config on the remote side look like when ppp is configured ?

New Member

Re: serial1 line is up , protocal is down

Hello, I think you should put a no keepalive command on the serial interface

tell me what happens.

396
Views
0
Helpful
13
Replies