Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Service Policy on 827 with PPPoA

I have an exising 827 configured for PPPoA using a dialer interface (dialer profile). If I create a Policy-Map and apply it to the Dialer interface for egress traffic the interface goes down. If I debug it complains about not having a dialer string - since a dailer string is not needed for this setup I am a bit stuck (debug message is cannot dial, no dialer string). I can add a dummy dialer string but it still doesnt work. I understand the 827 isn't the most featured router in the world but is there an alternative way to set this up so I can apply a service policy on the interface (be it dialer or other). I need to use PPPoA and CHAP/PAP authentication.

5 REPLIES
Cisco Employee

Re: Service Policy on 827 with PPPoA

We need to see the running config from 827 to know how you have configured policy-map. Dialer string not required for dsl config. By the way here is the config help for Qos on 827

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_fix/826/swg/advconf.htm

Re: Service Policy on 827 with PPPoA

Thanks for replying - the relevent bits of the config below:

interface ATM0

no ip address

load-interval 30

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

!

interface ATM0.38 point-to-point

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Dialer1

ip address negotiated

ip access-group 111 in

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname XXXX

ppp chap password XXXX

!

dialer-list 1 protocol ip permit

!

There is some more config (ACLs, & IP inspection) but I don't think these are relevent. I added the config below when testing some other stuff out for a customer and this is when the problem appeared:

class-map match-any MANAGEMENT

match ip dscp cs6 cs7

class-map match-any VOICE-CONTROL

match ip dscp af31 af32 af33

class-map match-any VIDEO

match ip dscp af41 af42 af43

class-map match-any VOICE

match ip dscp ef

class-map match-any default

match ip dscp af21 af22 af23

!

!

policy-map WAN-QoS

class VOICE

priority percent 15

class MANAGEMENT

bandwidth percent 2

class VIDEO

bandwidth percent 15

class VOICE-CONTROL

bandwidth percent 5

class UNSPECIFIED

bandwidth percent 15

Re: Service Policy on 827 with PPPoA

Thanks for all the really helpful replies........not ;o)

Anyway this is obviously a 'bug' but the workaround is real simple - reload the router............ If you make any changes to the policy-map later on and need to remove and re-add it then its another reload. Strange I know but that is the only way I can get the service policy to be applied.

As far as I can tell it must be because the Dialer interface (PPPoA) is up and connected when I am making changes. If its up and any changes (and I mean any...) are made to the Dialer interface it goes down and complains about not having a dialer string. If the changes are made and saved and then the router is reloaded it works fine.

Andy

Cisco Employee

Re: Service Policy on 827 with PPPoA

Hi Andrew

searching on bugtoolkit etc I also feel this is software issue .

Are you running latest IOS ?

Nilesh

Re: Service Policy on 827 with PPPoA

Nilesh

Not the very latest (12.2(15)T), I am runnning 12.2(13)T1, but this occurred on all releases of 12.2 I have tried - except 12.2(15)T as I had more severe issues with that......

145
Views
0
Helpful
5
Replies
CreatePlease to create content