Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Service-policy on gigabit interface not working

Hi there!

I have an 6500 IOS switch where i am using a policy for Voip trafic and i works for serial interface but not for my Gigabit interface

!

class-map match-all VOICE-CONTROL

match ip dscp cs3

class-map match-all VOICE

match ip dscp ef

!

!

policy-map WAN

class VOICE

priority percent 33

class VOICE-CONTROL

bandwidth percent 2

class class-default

fair-queue

can somone explain why this does not work on an giagbit interface ??

6 REPLIES
Cisco Employee

Re: Service-policy on gigabit interface not working

Hi,

The catalyst 6500 does not support WFQ - weighted fair queuing. This feature is only supported in the 6k on wan ports (flex wan and osm modules), which is why it works on your serial interface. QoS on the 6500's are on done on the PFC in hardware. The queue architecture and qos queuing features - WRR and WRED are implemented with fixed configurations on the asics. There are several qos features that are configurable, even though they are not supported - fair-queue being one of them. You have the options of implementing WRR along with priority queuing and as a queuing method, but not fair-queue.

For output scheduling, please refer to the following document for supported features:

http://www.cisco.com/warp/customer/473/73.html

HTH,

Bobby

Please rate helpful posts

New Member

Re: Service-policy on gigabit interface not working

Hi

Just want to say thank you, now i will try to see if i can understand the the doc , you posted to

Thanks

New Member

Re: Service-policy on gigabit interface not working

Hi,

I think a bit more info is required. Can you provide the output of:

sh policy-map int gx/y

sh run int gx/y

Do you trust dscp on incoming ports with "mls qos trust dscp"

Rgds

E.

New Member

Re: Service-policy on gigabit interface not working

Hi Again

Yes i trust DSCP on incoming int, ( it works on serial int,)

here is the out put for sh policy map and int. config . i have also put in the serial so you can see that it works on serial

sh run int gigabitEthernet 7/45

Building configuration...

Current configuration : 213 bytes

!

interface GigabitEthernet7/45

description Link til net 10.190.0.0 (DSB skolen) Colt-CirID:CPHCPHLE-065339

bandwidth 10000

ip address 172.30.9.9 255.255.255.252

speed 10

duplex full

mls qos trust dscp

end

##########################################################################

#sh policy-map interface gigabitEthernet 7/45

GigabitEthernet7/45

Service-policy output: WAN

queue stats for all priority classes:

queue size 0, queue limit 825

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

Class-map: VOICE (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip dscp ef

Priority: 33% (3300 kbps), burst bytes 82500, b/w exceed drops: 0

Class-map: VOICE-CONTROL (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip dscp cs3

queue size 0, queue limit 50

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

bandwidth 2.00%, kbps 200

Class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

queue size 0, queue limit 1625

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

Fair-queue: per-flow queue limit 406

#####################################################################

#sh ru interface serial 3/1/0

Building configuration...

Current configuration : 219 bytes

!

interface Serial3/1/0

description 34Mb Link til 10.30.1.72 interf.1/0 (Fredericia St.) HK 261125

bandwidth 34010

ip address 10.170.0.1 255.255.0.0

framing g751

dsu bandwidth 34010

service-policy output WAN

end

#sh policy-map interface serial 3/1/0

Serial3/1/0

Service-policy output: WAN

queue stats for all priority classes:

queue size 0, queue limit 831

New Member

Re: Service-policy on gigabit interface not working

Thanks for posting the config.

What I find strange is that your service-policy does not appear in the output of the sh run int command, yet when you do sh poli int g7/45 you get the output.

I take it you have configured the port as no switchport. I have noticed on 6500s that sometimes the ports accept an ip address even though they may not have been defined as routed ports. And what is more annoying the command does not appear in the sh run output.

I have applied similar commands onto a test port and it appears on mine..

class-map match-all test

match protocol rtp

policy-map test

class test

priority percent 33

class class-default

fair-queue

interface GigabitEthernet1/5

ip address 192.1.0.1 255.255.255.0

speed 10

duplex full

mls qos trust dscp

no cdp enable

spanning-tree portfast

spanning-tree guard root

service-policy output test

end

GigabitEthernet1/5

Service-policy output: test

queue stats for all priority classes:

queue size 0, queue limit 825

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

Class-map: test (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: protocol rtp

Priority: 33% (3300 kbps), burst bytes 82500, b/w exceed drops: 0

Class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

queue size 0, queue limit 1675

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

Fair-queue: per-flow queue limit 418

Also to clarify another point. Are you saying that it does not work because the service-policy does not appear on the sh run int output?

Rgds

E.

New Member

Re: Service-policy on gigabit interface not working

Hi Again ,,

Sorry my mistake it is in the config , i was cut- past from an old config,

the interface is a routed interface, it is used the same way as serial interface 3/1/0 byt our line supply Ethernet L2 Wan link.

i am saying that there is no hit in the sh polycy - map not even in the default class.

as i understand untill now it seems like i have to buy OSM GE wan module to make this work , but they are wery expencive $$$$$$$

interface GigabitEthernet7/45

description Link til net 10.190.0.0 (DSB skolen) Colt-CirID:CPHCPHLE-065339

bandwidth 10000

ip address 172.30.9.9 255.255.255.252

speed 10

duplex full

mls qos trust dscp

service-policy output WAN

end

276
Views
5
Helpful
6
Replies
CreatePlease login to create content