Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

set ip next-hop verify-availability

Apologies for the rather long message!

If I enable "set ip next-hop verify-availability", my policy routing fails (i.e. normal def. gw of router is taken):

interface Port-channel1.121

encapsulation dot1Q 121

ip address 203.149.69.49 255.255.255.252

ip policy route-map unlimited-traffic-test

!

route-map unlimited-traffic-test permit 10

match ip address 105

set ip next-hop 203.149.66.198

set ip next-hop verify-availability

!

access-list 105 remark ACL for Policy Routing to force certain subnets via Open-pipe and redundant secondary

access-list 105 deny ip any 203.149.64.0 0.0.15.255

access-list 105 deny ip any 203.63.239.0 0.0.0.255

access-list 105 deny ip any 210.10.54.0 0.0.0.255

access-list 105 deny ip any 210.10.55.0 0.0.0.255

access-list 105 permit ip 203.149.69.48 0.0.0.3 any

Feb 12 14:26:15.573 aest: IP: s=203.149.69.50 (Port-channel1.121), d=203.94.129.130, len 38, FIB policy match

Feb 12 14:26:15.573 aest: IP: s=203.149.69.50 (Port-channel1.121), d=203.94.129.130, len 38, FIB policy rejected - normal forwarding

Feb 12 14:26:15.581 aest: IP: s=203.149.69.50 (Port-channel1.121), d=203.94.129.130, len 38, FIB policy match

Feb 12 14:26:15.581 aest: IP: s=203.149.69.50 (Port-channel1.121), d=203.94.129.130, len 38, FIB policy rejected - normal forwarding

If I remove set ip next-hop verify-availability, then the policy-routing is honoured.

I have "ip cef" enabled on both routers.

My ideal scenario is to have a "primary" def gw for certain subnets, and in the event of that gw becoming unavailable, a secondary gw is taken -

route-map unlimited-traffic-test permit 10

match ip address 105

set ip next-hop 203.149.66.198 203.63.121.150

!

But if the first IP in next-hop is down, traffic goes no-where - Hence the reason I believe I need "set ip next-hop verify-availability" working?

Thanks in advance.

Regards,

MB

6 REPLIES
New Member

Re: set ip next-hop verify-availability

Hi MB,

The command "set ip next-hop verify-availability" works on Cisco Discovery Protocol (CDP), please enable CDP on the router, this might do the trick..

Cheers,

Sai.

New Member

Re: set ip next-hop verify-availability

Can confirm that cdp is already enabled on both routers.

Regards,

MB

New Member

Re: set ip next-hop verify-availability

Hi MB,

This command first appeared in Cisco IOS Release 12.0(3)T.

Can you check the IOS version of the routers that you are using??? (I am assuming that your IOS supports this command)..

-Sai.

New Member

Re: set ip next-hop verify-availability

Certainly -

Router 1 (7206VXR):

>sh ver

Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-IS-M), Version 12.1(5)T6, RELEASE SOFTWARE (fc1)

Router 2 (2651):

>sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IK8O3S-M), Version 12.2(19a), RELEASE SOFTWARE (fc2)

Regards,

MB

Bronze

Re: set ip next-hop verify-availability

I don't know what the cause of your issue is but you may want to consider this new feature as of 12.3(4)T: http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801d1e95.html

Much better than relying on CDP for routing decisions, IMO.

New Member

Re: set ip next-hop verify-availability

Looks Excellent - My only issue is that my remote router is 'remote'! - I would have to fly there to upgrade the IOS.

Has anyone succeeded in using set ip next-hop verify-availability?

Regards,

MB

693
Views
0
Helpful
6
Replies
CreatePlease to create content