Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Setting up trunk link between 3745 and 2950

Hi,

I need some help to setup a trunk link between the 3745 and the 2950.

The problem is that I am not familiar with the 3745 router and when I enter interface configuration mode, it has only the command 'trunk-group' which it says it is only for ISDN. I am setting up a normal ethernet link.

What would the configuration be on the 3745 equipment ?

Thanks in advance,

-SN-

10 REPLIES
Purple

Re: Setting up trunk link between 3745 and 2950

Hi,

The way to setup the trunk link on a router interface is to create sub-interfaces corresponding to each VLAN. For example:

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.100

ip address x.x.x.x y.y.y.y

encapsulation dot1q 100

!

interface FastEthernet0/0.200

ip address x.x.x.x y.y.y.y

encapsulation dot1q 200

!

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: Setting up trunk link between 3745 and 2950

Hi,

This is what I think the configuration should be on the 2950 switch.

conf t

interface fa0/33

switchport mode trunk

switchport trunk allowed vlan 101,102,104

end

This is connected to the other end to the 3745 router on ports fa1/0 whereby I have created the vlans 101,102 and 104.

[1] What I am stuck is where do I give it an IP on the 2950 for it to communicate to the 3745 router ?

The IPs on the 3745 subinterfaces are 30.201,30.209 and 30.217

172.21.30.201 - 172.21.30.206

172.21.30.209 - 172.21.30.214

172.21.30.217 - 172.21.30.222

[2] What else should I do to make this switch communicate to the 3745 router ?

[3] Also is there any documentation that I can look up for configuration references and samples.

Thank you,

- SN -

Re: Setting up trunk link between 3745 and 2950

Hi Sanjay,

What you want is intervlan routing using an external router 3745 in your case.

Have a look at this link with topology and configuration

http://www.cisco.com/warp/customer/473/50.shtml#801.1Q

Also the subinterfaces ip address will be the gateway on workstation on respective vlans and to let 2950 cumminicate to your router you have to have an ip addres on 2950 on any of the vlans which you have created on subinterfaces but make sure on 2950 being a layer 2 switch you can have only one interface vlan active and can assign an ip address on it.

HTH, if yes please rate the post.

Ankur

New Member

Re: Setting up trunk link between 3745 and 2950

Ankur,

Yes, I read the doc and understand it now. I will try this out soon.

Btw, how do you find these documentations rather fast from the cisco website ? I am not able to get the right documentation to solve my problems to date.

Thank you sir,

-SN-

Re: Setting up trunk link between 3745 and 2950

Hi Sanjay,

Lot of documents are from my favorite list but you can visit

www.cisco.com/univercd

When you open this link you will there is a drop down menu for switches and when you get it open you will see lot of IOS release and then you can click on software confguration guide to check different cofigs and features.

HTH, if yes please rate the post.

Ankur

New Member

Re: Setting up trunk link between 3745 and 2950

Hi,

I manage to setup this 3745 and 2950 but here is the problem that I noticed :-

1) I can ping from the 3745 to the 2950 and a host on vlan101.

2) From the host, I cannot ping the gateway of the other vlan which is the subinterface on the 3745 nor can the traffic go out to the campus network.

3) Since it cannot ping the gateway of the other vlan, I am not too sure if routing is turned on the 3745. I have typed in 'ip routing' but when I do a

'show run' it does not seem to be there.

I have attached the config of the 3745 router and the 2950 switch. What do I need to do to allow the host on the 2950 to ping the other subinterfaces and go to the broader network.

Please advice,

-SN-

Re: Setting up trunk link between 3745 and 2950

Hi Sanjay,

You will not see "ip routing" in sh run because it is by default enabled and any command which is by default enabled will not be displayed in sh run but yes if you disable it you will see it in sh run because that is not the default behavior.

Now coming to te problem this happens many a times when you cofigure intervlan routing an sometime IOS behave wierd. Because there is no reason why it should not ping the ip which are directly connected on the router.

But let us confirm if trunk is up or not cause most probably that could be the issue. Can you paste the output of "sh interface FastEthernet0/33 switchport" from the switch and also paste the output of "sh ip route" from the router.

Regards,

Ankur

New Member

Re: Setting up trunk link between 3745 and 2950

#sh interface FastEthernet0/33 switchport

Name: Fa0/33

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: 101,102,104

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

#

---------------------------------------------------------------------------------

#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.21.0.0/16 is variably subnetted, 5 subnets, 3 masks

C 172.21.30.192/30 is directly connected, GigabitEthernet3/0

C 172.21.30.200/29 is directly connected, FastEthernet1/0.101

C 172.21.30.208/29 is directly connected, FastEthernet1/0.102

C 172.21.30.216/29 is directly connected, FastEthernet1/0.104

S 172.21.0.0/16 [1/0] via 172.21.30.193

New Member

Re: Setting up trunk link between 3745 and 2950

Ankur,

I am also using this static route 172.21.0.0/16 so that it can talk to the campus network. I am doing this instead of enabling eigrp. This is okay right ?

-SN-

New Member

Re: Setting up trunk link between 3745 and 2950

Ankur,

I have enabled eigrp on the router and everything is working fine now. I am a bit confused now reason being is that I thaught that

1) static routes would be the same as a dynamic route in this instance. The static route that I used on the router that I was setting on was :-

ip route 172.21.0.0 255.255.0.0 172.21.30.193

which says that direct all trafic from 172.21.0.0/16 to the ip 172.21.30.193 which is the next hop ip of this router.

[1] Isn't the static route and enabling eigrp would mean the same thing here ?

[2] Do I need a default gateway for this router ?

Problem solved but I need to really understand what is going on here.

Thank you very much for you help so far Ankur.Appreciate it.

-SN-

835
Views
14
Helpful
10
Replies