Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Simple Configuration not so simple?

This is my first time posting here and hope this is the right place to start.

We just switched over our frame sites to point to point T1. Had the lowest bidder (We are a government agency) come in to configure our routers, nothing has worked right yet. We have gone through 2 consultant from this company. We have two issues but was wondering If anyone else has any tips for the configuration - if you notice anything missing or just outright wrong:

#1. A site keeps keeps going up and down. It's at random times. I'm having the line check done on it, but I've been advise that a misconfigured clock source can cause this.

#2. DHCP cannot send offer to workstation over the new lines. The workstation makes a request and DHCP see's it, it sends an OFFER but it seems like the router isn't forwarding it on. I have a post about it with more info at novell site (see link at bototm)- not sure if its a CISCO issue or a NOVELL issue...

We have a 7204 VXR with an 8 port CSU/DSU at our HQ

We have 1760 ciscos on the remote end

I only see a clock source on the 7204 VXR in the Config.

Heres the 7204 VXR Config at HQ, I've only included two controller's and two serial in the configure.. they are all the same:

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname K00LRTR01

!

enable secret #############.

enable password ##############

!

no ip subnet-zero

ip cef

!

!

no ip domain lookup

!

controller T1 1/0

framing esf

clock source internal

linecode b8zs

channel-group 1 timeslots 1-24

description "Connection to bob"

!

controller T1 1/1

framing esf

clock source internal

linecode b8zs

channel-group 1 timeslots 1-24

description "Connection to mary"

!

!

interface FastEthernet0/0

ip address 172.22.1.8 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0:1

description "Connection to Bob"

ip address 172.22.136.2 255.255.255.0

!

interface Serial1/1:1

description "Connection to Mary"

ip address 172.22.161.2 255.255.255.0

!

!

router eigrp 200

network 172.22.0.0

no auto-summary

no eigrp log-neighbor-changes

!

router rip

version 2

network 172.22.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.22.1.1

no ip http server

!

call rsvp-sync

!

mgcp profile default

!

dial-peer cor custom

!

gatekeeper

shutdown

!

!

End (after all the login stuff)

Now on the far end, 1760 router looks like:

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname KATRTRO1

!

enable password ########

!

no ip subnet-zero

no ip domain lookup

!

interface FastEthernet0/0

ip address 172.22.15.1 255.255.255.0

ip helper-address 172.22.1.50

speed auto

!

interface Serial0/0

description "Connection to Bob"

ip address 172.22.136.1 255.255.255.0

no fair-queue

!

router eigrp 200

network 172.22.0.0

no auto-summary

no eigrp log-neighbor-changes

!

router rip

version 2

network 172.22.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.22.136.2

no ip http server

!

!

END (after login stuff)

LINK to novell posting:

http://support-forums.novell.com/group/novell.support.os.server.dns-dhcp/readerNoFrame.tpt/@thread@11491@F@10@D-,D@ALL/@article@11497

4 REPLIES
Silver

Re: Simple Configuration not so simple?

Ensure that one side is configured to provide clock, this would be the internal setting , the other end should be set to clock source network. This means that it is looking for clock from the network. A good indication of a clocking issue is if you see a lot of aborts in your show interface serial x . Another thing you may want to check is call your provider and make sure they are not providing clock. If they are you should set the clock source to network on both ends.

Anonymous
N/A

Re: Simple Configuration not so simple?

Just some quick thoughts. These are not meant to be solutions but these are the first things that I would look at from the small amount of info you provided.

1. You are running RIP V2 which is classless. However, RIP V2 is normally configured in two places, in router mode (which you have) and interface mode (which you do not). You need to specify an interface as RIP2, both sending and receiving. Ohterwise RIPV1 updates will be sent out of the interfaces. Being that RIP1 is classful your T1's may look as if they are on the same subnet giving you IP routing problems. Looking at your config I would lose the RIP 2 all together (and the EIGRP). The 1760 is isolated and only requires a default route. Just make sure the statics are in the 7204 for the net behind the 1760.

2. Clocking. Check the clocking on the CSU/DSU at the remote site (1760). It should be set for line. If it is not then you have a problem. If the telco is providing a clock signal then you also have a problem on the 7204 providing an internal clock source.

http://www.cisco.com/en/US/products/hw/routers/ps233/products_tech_note09186a0080093c5d.shtml

3. DHCP. DHCP is non-routable. It is essentially a bootp request. In order for DHCP work you need to use ip helper-address command. Just look that up on cisco.

Kevin

New Member

Re: Simple Configuration not so simple?

Thanks for the responses so far...

RIP and EIGRP

We are running rip2 right now because we have some ISDN and Frame Relay sites still running (converting one site at a time, we have a total of 7 sites converting over point-to-point t1). We need the rip2 on so the new sites can get the only site routes. Once everything is converted over we will loose the rip2. We need to keep, as far as I know, eigrp so the sites will know about eachother. As far as setting up rip2 in interface mode

is it

ip rip send version 2

ip rip receive version 2

What's the rule as far as what interface to configure it to? Serial and Ethernet on both routers? I'll do some reading up - but any advice would be great.

CLOCKING

Thanks I will call my provider and see if they provide clock.

DHCP

Yep - I already have the ip helper-address command in the config. Still not passing the DHCPOFFER to the workstations.

Anonymous
N/A

Re: Simple Configuration not so simple?

RIP and EIGRP -

I always prefer not to run routing protocols all the way to the edge(your 1700) if it is unnecessary. In this case, it does not seem necessary. Just use statics at the 7204 and redistrbute them into the routing protocol, rip or eigrp. But, that is just a preference. I feel it makes for easier troubleshooting if you only use routing protocols at the core.

The rip config looks right, you need to apply it to every interface that will advertise and receive routes.

You got me on the DHCP, could be related to the routing.

90
Views
0
Helpful
4
Replies
CreatePlease to create content