Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Simple dialin to an 831 router

Has anyone here been able to connect a modem to the console/aux port of an 831 router and cleanly dial into it to get to the exec prompt? I have done this on many other routers with no problems. I seem to get a lot of garbage characters when doing this on the 831 series routers. I have a tac case open and they have suggested numerous modemcap entries to try but the result is the same with each of them. I would just like to know if anyone else has been able to make this work on an 831 router. I've tried using USR Courier and Sportster modems.

5 REPLIES
VIP Purple

Re: Simple dialin to an 831 router

Hello,

I do not know which IOS version you are using, but check out this sample config for a 831 running 12.2 (in this example the AUX port has been configured for dialin and dialout). You might have to specify the speed and stop bits in your AUX port config:

Configuration Example for the Cisco 831 Router

The following example configures dial backup and remote management on a Cisco 831 router.

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

memory-size iomem 20

enable password cisco

!

ip subnet-zero

ip name-server 206.13.28.12

ip name-server 206.13.31.12

ip name-server 63.203.35.55

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool 1

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

! Need to use your own correct ISP phone number

modemcap entry MY-USER_MODEM:MSC=&F1S0=1

chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT 5555102\T"

TIMEOUT 45 CONNECT \c

!

!

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

hold-queue 100 out

!

interface Ethernet1

no ip address

no ip route-cache

no ip mroute-cache

pppoe enable

pppoe-client dial-pool-number 1

!

!Dial backup and remote management physical interface

interface Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 3

async default routing

async dynamic routing

async mode dedicated

ppp authentication pap callin

!

! Primary wan link

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp pap sent-username account password 7 pass

ppp ipcp dns request

ppp ipcp wins request

ppp ipcp mask request

!

! Dialer backup logical interface

interface Dialer3

ip address negotiated

ip nat outside

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool 3

dialer idle-timeout 60

dialer string 5555102 modem-script Dialout

dialer watch-group 1

!

! Remote management PC ip address

peer default ip address 192.168.2.2

no cdp enable

!

! Need to use your own ISP account and password

ppp pap sent-username account password 7 pass

ppp ipcp dns request

ppp ipcp wins request

ppp ipcp mask request

!

! IP NAT over Dialer interface using route-map

ip nat inside source route-map main interface Dialer1 overload

ip nat inside source route-map secondary interface Dialer3 overload

ip classless

!

! When primary link is up again, distance 50 will override 80 if dial backup hasn't timeout

! Multiple routes because peer ip address are alternated among them when CPE gets connected

ip route 0.0.0.0 0.0.0.0 64.161.31.254 50

ip route 0.0.0.0 0.0.0.0 66.125.91.254 50

ip route 0.0.0.0 0.0.0.0 64.174.91.254 50

ip route 0.0.0.0 0.0.0.0 63.203.35.136 80

ip route 0.0.0.0 0.0.0.0 63.203.35.137 80

ip route 0.0.0.0 0.0.0.0 63.203.35.138 80

ip route 0.0.0.0 0.0.0.0 63.203.35.139 80

ip route 0.0.0.0 0.0.0.0 63.203.35.140 80

ip route 0.0.0.0 0.0.0.0 63.203.35.141 80

ip route 0.0.0.0 0.0.0.0 Dialer1 150

no ip http server

ip pim bidir-enable

!

! PC ip address behind CPE

access-list 101 permit ip 192.168.0.0 0.0.255.255 any

access-list 103 permit ip 192.168.0.0 0.0.255.255 any

!

! Watch multiple ip addresses because peers are alternated among them when CPE gets connected

dialer watch-list 1 ip 64.161.31.254 255.255.255.255

dialer watch-list 1 ip 64.174.91.254 255.255.255.255

dialer watch-list 1 ip 64.125.91.254 255.255.255.255

!

! Dial backup will kick in if primary link is not available 5 minutes after CPE starts up

dialer watch-list 1 delay route-check initial 300

dialer-list 1 protocol ip permit

!

! To direct traffic to an interface only if the Dialer gets assigned with an ip address

route-map main permit 10

match ip address 101

match interface Dialer1

!

route-map backup permit 10

match ip address 103

match interface Dialer3

!

!

line con 0

exec-timeout 0 0

!

! Change console to aux function

modem enable

stopbits 1

line aux 0

exec-timeout 0 0

!

! To enable and communicate with the external modem properly

script dialer Dialout

modem InOut

modem autoconfigure discovery

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

exec-timeout 0 0

password cisco

login

!

scheduler max-task-time 5000

end

Regards,

Georg

New Member

Re: Simple dialin to an 831 router

Thanks for the reply Georg. I am running 12.2 code. Actually I am already specifying the speed and stopbits in the config. If you have any further thoughts please pass them along.

Thanks,

Mike

VIP Purple

Re: Simple dialin to an 831 router

Hello,

you might want to try and reset the modem to factory defaults. Not sure if you already know this document, it has a detailed description of how to let a USR modem work with a Cisco router:

Attaching a US Robotics Modem to the Console Port of a Cisco Router

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_tech_note09186a00800941c9.shtml

Regards,

GP

New Member

Re: Simple dialin to an 831 router

Hi,

As a matter of fact, I have done this plenty of times using other model routers. I was hoping to find somebody who has actually done it successfully with an 831. I bought three of these routers and have not been able to get this to work cleanly on any of them. I have even upgraded IOS on one of them thinking it might have been an IOS bug.

I appreciate your suggestions.

Mike

VIP Purple

Re: Simple dialin to an 831 router

Hello Mike,

stupid question maybe, but what kind of cable are you using ? The cable that is actually used for connecting the modem to the console/virtual AUX port on the 831 is Cisco part number CAB-CONAUX=, straight serial cable - RJ45 to DB25 male.

Regards,

Georg

296
Views
0
Helpful
5
Replies
CreatePlease to create content