Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Simple Question

Hi all,

I'm just starting out with the whole CCNA thing and I've been playing with Routersim. To start I thought I'd do a basic setup - unfortunately it doesn't seem to work as I expected.

The setup is;

[HOST A - 10.2.0.2/16 GW.10.2.0.1]

||||

[int fastEthernet 0/0 10.2.0.1/16]

[2600 ROUTER]

[int fastEthernet 0/1 10.1.0.1/16]

||||

[HOST B - 10.1.0.2/16 GW 10.1.0.1]

I don't have the IOS config offhand. Basically I've configured the interfaces and made sure they are "no shutdown". I can ping both hosts from the router, which tests the ethernet connectivity. I just can't ping host->host when the traffic traverses the interfaces.

I then thought it'll be because there are no static routes. So I added them;

ip route 10.1.0.0 255.255.0.0 10.1.0.1

ip route 10.2.0.0 255.255.0.0 10.2.0.1

I did a "copy run start" and reloaded the router. Still I cant ping host->host.

When I do a show IP route, it displays the two interfaces and their subnets as connected, it also displays the static routes I've added.

Is this a limitation of the routerSim software and is my config correct? Or have I missed something really obvious?

I havent got access to any "real" routers for another week or so.

All help is appreciated.

  • Other Network Infrastructure Subjects
6 REPLIES

Re: Simple Question

Ok joey, The static routes are not required. The two networks are directly connected so they should always be routed.

A few thing might be missing:

In the 2600 you may need to specify the encapsulation as these interfaces can also be set up as trunks.

A wrong subnetmask somewhere might be another problem. Please double-check.

Any access-lists still present in the config?

The best test is to do it step by step.

1 From host-A to its default gateway

2 From host-A to router interface 0/1

3 From host-A to host-B

if it fails on

1 check connectivity and IP settings on the host and router int FA0/0

2 check interface status on the router

3 check host-B

Goodluck,

Leo

New Member

Re: Simple Question

Hi Leo,

Thanks for your reply;

The config is as follows

===================

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router-2612

!

enable secret xxxxx

!

ip subnet-zero

!

interface FastEthernet0/0

ip address 10.1.0.1 255.255.0.0

no ip directed-broadcast

!

!

interface FastEthernet0/1

ip address 10.2.0.1 255.255.0.0

no ip directed-broadcast

!

interface Serial0/0

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0/1

no ip address

no ip directed-broadcast

shutdown

!

!

no ip classless

!

!

!

line con 0

line aux 0

line vty 0 4

!

end

===================

From HostA :

I can ping its default gateway, I can ping the other interface (0/1), unable to ping HostB

From HostB :

I can ping its default gateway, I can ping the other interface (0/0), unable to ping HostA

So it seems its not routing the traffic out of the opposite interface. I've checked the IPConfigs on both hosts and their IP/Subnets are set correctly.

HostA - 10.1.0.2/16 gw 10.1.0.1

HostB - 10.2.0.2/16 gw 10.2.0.1

The show ip route displays;

====================

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets

C 10.2.0.0 is directly connected. FastEthernet0/1

C 10.1.0.0 is directly connected. FastEthernet0/0

====================

By interface encapsulation do you mean PPP, framerelay or suchlike? Would that matter on a plain jane ethernet network?

There are no access lists in place.

The only oddity is when i do a show interface command, interface 0/1 displays a 0.0.0.0 for its internet address, yet shows as 10.2.0.1 in the config and it responds to a ping! There are no duplicate addresses on hosts or anything.

Starting to look like its a routerSim problem, or have i missed something

Thanks again

Joe

Re: Simple Question

Hi,

try

ip classless.

This might help.

Regards,

Milan

Re: Simple Question

IP clasless will not make a difference as both networks are directly connected. If it does, the simulation is not correct.

Leo

Re: Simple Question

Joe,

By encapsulation I mean something like:

encapsulation dot1Q / ISL

As far as I can see, your config should work on a router.

I have no experience with the router simulation software so it could be anything. Most likely it is something with RouterSim.

Leo

New Member

Re: Simple Question

Joey,

Have you enabled IP Routing?

# conf t

(config)# ip routing

(config)# cntrl-z

# copy run star

#

Hope it helps

rich_sends

90
Views
0
Helpful
6
Replies
This widget could not be displayed.