Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Slow performance with 2 new full T1 installed .

We've just added second Full T1 line to

this router to dedicate full T1 bandwidth our two database servers.We are still experiencing the slow performance to our remote location such as file copying and acceessing applications.below are configs and sh run.Any help and inputs are greatly appreciated.Is the router configuration correct? or need to be modified.Thanks

Danny.

router2621xm#sh run

Building configuration...

Current configuration : 1924 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname OPS

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

enable password xxxx

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

no ftp-server write-enable

!

class-map match-any VOIP

match ip dscp ef

policy-map VOIP-QOS

class VOIP

priority 1158

class class-default

fair-queue

random-detect dscp-based

!

interface FastEthernet0/0

ip address 192.168.157.1 255.255.255.0 secondary

ip address 192.168.7.1 255.255.255.0

ip policy route-map policyroute speed auto

full-duplex

no mop enabled

!

interface Serial0/0

ip unnumbered FastEthernet0/0

service-policy output VOIP-QOS

no ip mroute-cache

!

interface Serial0/1

ip unnumbered FastEthernet0/0

service-policy output VOIP-QOS

no ip mroute-cache

router eigrp 15

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

network 192.168.5.0

network 192.168.6.0

network 192.168.7.0

network 192.168.8.0

network 192.168.151.0

network 192.168.152.0

network 192.168.153.0

network 192.168.154.0

network 192.168.155.0

network 192.168.156.0

network 192.168.157.0

network 192.168.158.0

network 192.168.201.0

no auto-summary

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.5

no ip http server

!

access-list 150 permit ip host 192.168.7.5 any

access-list 150 permit ip host 192.168.7.6 any

access-list 151 permit ip any any

dialer-list 1 protocol ip permit

route-map policyroute permit 10

match ip address 150

set interface Serial0/1

route-map policyroute permit 20

match ip address 151

set interface Serial0/0

line con 0

line aux 0

line vty 0 4

password xxxx

login

end

4 REPLIES
VIP Purple

Re: Slow performance with 2 new full T1 installed .

Hello,

I assume what you want is load-balance your traffic over both T1 links ? I am not sure that this is happening with your current configuration. Can you do a ´show ip route´ and check if there are two paths to your remote location. If not, use the comand ´variance´ under your EIGRP configuration in order to enable load-balancing. The actual value of the ´variance´ command depends on the metric of the primary path, check this link for an explanation:

Load Balancing

http://www.cisco.com/warp/public/103/eigrp-toc.html#loadbalancing

HTH,

GP

Purple

Re: Slow performance with 2 new full T1 installed .

Also remember you have given preference for any voice traffic that may be running across that link at the time with your QOS setup , data is second in line . On your fastethernet check for any errors . I would set to whatever the switchsetup is , you have it as auto speed ,full duplex . Set it as auto for speed and duplex .

New Member

Re: Slow performance with 2 new full T1 installed .

A couple of items worth noting are the QOS policies themselves.

This is OK

class-map match-any VOIP

match ip dscp ef

Add this

class-map match-any VOIP-signalling

match dscp af31

match dscp cs3

Change the policy-map to reflect the changes

policy-map VOIP-QOS

class VOIP-signalling

bandwidth 16

class VOIP

priority 24

class class-default

fair-queue 256

random-detect dscp-based

The bandwidth is meant for 4 concurrent phone conversations so adjust up as needed. The priority is based on my own testing so take it as you may.

The most important statement is "fair-queue 256", by default you only get 16 queues. Allowing for 256 queues only uses a modest amount of memory so its a simple low impact choice for the router and allows more conversations between devices without interruption.

Upping the number of queues in your policy would be the best and most important item for your performance problem, next of couse to coercing EIGRP to load balance the T1s properly.

Brian

P.S. Create a loopback interface for the ip unnumbered use, cause if the Fa0/0 goes down everything goes down and you can't telnet in from anywhere to look at it. Eliminate the following items from the config by using "no" in fromt of them, a bit of research will tell you why, and start you toward eliminating a few other items.

service udp-small-servers

service tcp-small-servers

Re: Slow performance with 2 new full T1 installed .

Hi Danny,

you push your database server traffic through one T1 and the rest through the other T1 by use of PBR. Fine so far. There is nothing wrong with that, assuming your access-lists are ok. Are both servers really connected to F0/0? What about the return-path? Do you see dropped packets on the other end of your T1s? Do you also use PBR and sort out client traffic to the proper T1? Dropped ACKs could be really affecting your throughput massively.

Are you sure you do not run into other problems like TCP throughput (window size times RTT)? What is your roundtrip time? Do you see retransmissions for the slow applications?

Regards

Martin

125
Views
0
Helpful
4
Replies
CreatePlease to create content