Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SOHO 97 backup interface - does this really work?

Does anyone know how to configure a SOHO 97

to support modem dial backup to an ISP

using the "backup interface" method -

specifically how to get the router to recognise

the backup default route and switch from using

the ADSL interface to the backup dialer interface?

When I disconnect the ADSL line, debugging shows

that the ATM0 line goes down, but:

Di1 DDR: Cannot place call, no dialer string set

and the default route remains as Dialer1.

It is obviously still using "Di1" and

trying to find a dialer script for this.

I've tried creating a separate dialer-group

for interesting traffic for dialer1 and 2.

Still doesn't work. Running "start-chat"

manually dials the modem as expected.

I cannot find a specific example of dial

backup for the SOHO 97 anywhere on the net.

The SOHO 97 seems to support "backup

interface" commands, but doesn't support

"dialer watch" commands.

Does the SOHO 97 really support dial backup?

Relevant parts of config:

interface ATM0

no ip address

backup interface async1

backup delay 10 10

no ip mroute-cache

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

dsl operating-mode auto

!

interface Dialer1

ip address negotiated

no ip directed-broadcast

no cdp enable

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 7 zzz

ppp pap sent-username xxx password 7 yyy

hold-queue 224 in

!

interface Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 2

async default routing

async mode dedicated

!

interface Dialer2

ip address negotiated

encapsulation ppp

no ip directed-broadcast

no cdp enable

no ip route-cache

no ip mroute-cache

dialer pool 2

dialer-group 1

dialer idle-timeout 300

dialer remote-name pacific

dialer string nnnnnnnn modem-script dialout

ppp authentication chap pap

ppp chap hostname xxx

ppp chap password 7 zzz

ppp pap sent-username xxx password 7 yyy

ppp ipcp dns request

ppp ipcp mask request

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2 80

dialer-list 1 protocol ip permit

!

line aux 0

script dialer dialout

modem callout

modem autoconfigure type aopen

transport input all

stopbits 1

speed 57600

flowcontrol hardware

Thanks

-- Richard

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: SOHO 97 backup interface - does this really work?

Oops, that should have been distance 1 (or any other number lower than the distance of the Dialer1 route).

However, your log shows that the Async1 interface changes to down, not up, when atm0 goes down.

Which is logical now that I think of it.

Another thought however: can you go back to your original config (with Dialer2), but change the backup interface from Async1 to Dialer2, and configure the Dialer2 route with a lower distance than the Dialer1 route.

Making Di2 the backup route should bring it in Standby so the Di1 route is preferred. When Atm0 goes down, Di2 comes up(spoofing) so the Di2 route should be preferred. I hope :)

hth

Herbert

3 REPLIES
Bronze

Re: SOHO 97 backup interface - does this really work?

Just a thought (haven't got the equipment to test it myself):

Apply all your Dialer2 settings to Async1 and remove Dialer2:

interface Async1

ip address negotiated

encapsulation ppp

dialer remote-name pacific

dialer string nnnnnnnn modem-script dialout

etc.

no ip route 0.0.0.0 0.0.0.0 Dialer2 80

no interface Dialer2

Then define the backup route to Async1 as having a lower distance than the primary route:

ip route 0.0.0.0 0.0.0.0 Dialer1 10

ip route 0.0.0.0 0.0.0.0 Async1 0

My thinking behind this is that Async1 is in standby state as long as atm0 is up, so the route with distance 0 will not be used (since the nexthop interface is not up); when atm0 goes down, Async1 comes up and the route with distance 0 takes over.

Let us know if it works?

regards

Herbert

Community Member

Re: SOHO 97 backup interface - does this really work?

Hi Herbert

Thanks for replying.

I followed your advice as far as I could.

I can't set async1 route with distance 0 - IOS

doesn't allow it. It appears that async1 doesn't

come up - consecutive log messages:

4d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down

4d22h: %LINK-3-UPDOWN: Interface Async1, changed state to down

4d22h: Di1 DDR: Cannot place call, no dialer string set

I'm stumped.

Regards

-- Richard

Bronze

Re: SOHO 97 backup interface - does this really work?

Oops, that should have been distance 1 (or any other number lower than the distance of the Dialer1 route).

However, your log shows that the Async1 interface changes to down, not up, when atm0 goes down.

Which is logical now that I think of it.

Another thought however: can you go back to your original config (with Dialer2), but change the backup interface from Async1 to Dialer2, and configure the Dialer2 route with a lower distance than the Dialer1 route.

Making Di2 the backup route should bring it in Standby so the Di1 route is preferred. When Atm0 goes down, Di2 comes up(spoofing) so the Di2 route should be preferred. I hope :)

hth

Herbert

146
Views
0
Helpful
3
Replies
CreatePlease to create content