Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Soho 97 Dial Backup fails

Hi

I can't get dial backup working on a Soho 97.

The modem on the AUX port never dials.

Debugging reveals the error:

Di1 DDR: Cannot place call, no dialer string set

Relevant parts of config (sanitized):

modemcap entry aopen:MSC=&F1S0=0

chat-script dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT nnnnnn \T" TIMEOUT 60 CONNECT \c

!

interface ATM0

no ip address

backup interface async1

backup delay 10 10

no ip mroute-cache

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

dsl operating-mode auto

!

interface Dialer1

ip address negotiated

no ip directed-broadcast

ip access-group 110 in

ip inspect from_internal out

no cdp enable

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 7 zzz

ppp pap sent-username xxx password 7 yyy

hold-queue 224 in

!

interface Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 2

async default routing

async mode dedicated

!

interface Dialer2

ip address negotiated

encapsulation ppp

no ip directed-broadcast

ip access-group 110 in

ip inspect from_internal out

no cdp enable

no ip route-cache

no ip mroute-cache

dialer pool 2

dialer-group 1

dialer idle-timeout 300

dialer remote-name pacific

dialer string nnnnnnnn modem-script dialout

ppp authentication chap pap

ppp chap hostname xxx

ppp chap password 7 zzz

ppp pap sent-username xxx password 7 yyy

ppp ipcp dns request

ppp ipcp mask request

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1 150

dialer-list 1 protocol ip permit

!

line aux 0

script dialer dialout

modem callout

modem autoconfigure type aopen

transport input all

stopbits 1

speed 57600

flowcontrol hardware

Debugging settings:

debug atm events

debug ip routing

debug dialer

debug modem

debug chat line 1

debug ppp negotiation

Debugging output when DSL line unplugged

(to test dial backup):

00:55:48: %LINK-5-CHANGED: Interface Async1, changed state to standby mode

00:55:51: DSL: Defect: LOS LOF LCDf LOM: retraining

00:55:51: DSL: Received response: 0x41

00:55:51: Resetting ATM0

00:55:53: %LINK-3-UPDOWN: Interface ATM0, changed state to down

00:55:53: DSL: SM: [DMTDSL_SHOWTIME -> DMTDSL_RE_OPEN]

00:55:53: DSL: Send ADSL_CLOSE command.

00:55:53: DSL: Sent command 0x4

00:55:54: DSL: Received response: 0x25

00:55:54: DSL: Connection closed

00:55:54: DSL: SM: [DMTDSL_RE_OPEN -> DMTDSL_DO_OPEN]

00:55:54: DSL: Send ADSL_OPEN command.

00:55:54: DSL: Using subfunction 0x15

00:55:54: DSL: Using subfunction 0x15

00:55:54: LOCAL:Max noise margin for power cutoff 31

00:55:54: DSL: Sent command 0x3

00:55:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down

00:55:54: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down

00:55:54: Vi3 IPCP: Remove link info for cef entry 203.9.190.190

00:55:54: Vi3 CDPCP: State is Closed

00:55:54: Vi3 IPCP: State is Closed

00:55:54: Vi3 PPP: Phase is ESTABLISHING, renegotiate LCP

00:55:54: Vi3 PPP: No remote authentication for call-out

00:55:54: Vi3 LCP: O CONFREQ [Closed] id 12 len 10

00:55:54: Vi3 LCP: MagicNumber 0x0D5B454E (0x05060D5B454E)

00:55:54: %DIALER-6-UNBIND: Interface Vi3 unbound from profile Di1

00:55:54: RT: Pruning routes for Dialer1 (3)

00:55:54: RT: delete route to 203.9.190.190 via 0.0.0.0, Dialer1

00:55:54: RT: no routes to 203.9.190.190, flushing

00:55:54: RT: NET-RED 203.9.190.190/32

00:55:54: RT: NET-RED queued, Queue size 1

00:55:54: RT: delete network route to 203.9.190.0

00:55:54: RT: NET-RED 203.9.190.0/24

00:55:54: RT: NET-RED queued, Queue size 2

00:55:54: Vi3 LCP: State is Closed

00:55:54: Vi3 PPP: Phase is DOWN

00:55:54: RT: delete route to 203.100.236.210 via 0.0.0.0, Dialer1

00:55:54: RT: no routes to 203.100.236.210, flushing

00:55:54: RT: NET-RED 203.100.236.210/32

00:55:54: RT: NET-RED queued, Queue size 1

00:55:54: RT: delete network route to 203.100.236.0

00:55:54: RT: NET-RED 203.100.236.0/24

00:55:54: RT: NET-RED queued, Queue size 2

00:55:54: RT: delete route to 0.0.0.0 via 0.0.0.0, Dialer1

00:55:54: RT: no routes to 0.0.0.0, flushing

00:55:54: RT: NET-RED 0.0.0.0/0

00:55:54: RT: NET-RED queued, Queue size 1

00:55:54: RT: NET-RED 0.0.0.0/0

00:55:54: RT: NET-RED queued, Queue size 2

00:55:54: Di1 IPCP: Remove route to 203.9.190.190

00:55:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down

00:55:55: RT: add 0.0.0.0/0 via 0.0.0.0, static metric [150/0]

00:55:55: RT: NET-RED 0.0.0.0/0

00:55:55: RT: NET-RED queued, Queue size 1

00:55:55: RT: default path is now 0.0.0.0 via 0.0.0.0

00:55:55: RT: new default network 0.0.0.0

00:55:55: RT: NET-RED 0.0.0.0/0

00:55:55: RT: NET-RED queued, Queue size 2

00:55:56: Di1 DDR: Cannot place call, no dialer string set

Any help gratefully received.

Richard

  • Other Network Infrastructure Subjects
3 REPLIES
Bronze

Re: Soho 97 Dial Backup fails

hi

the new default route points to Dialer 1. Under the configuration of Dialer 1

you did not define the dialer string...you can see that in the following debug lines:

00:55:55: RT: new default network 0.0.0.0

00:55:55: RT: NET-RED 0.0.0.0/0

00:55:55: RT: NET-RED queued, Queue size 2

00:55:56: Di1 DDR: Cannot place call, no dialer string set

Just define a dialer string under the inteface Dialer 1 and you should

get a step further.

Hope that helps

Roger

New Member

Re: Soho 97 Dial Backup fails

Hi Roger

Thanks for replying. I added "dialer string" to dialer1

as you suggested. I got new diagnostics. It doesn't

dial though. The debugging now shows:

00:02:42: Vi3 DDR: rotor dialout [priority]

00:02:42: Vi3 DDR: Dialing cause ip (s=61.8.4.81, d=61.8.0.2)

00:02:42: Vi3 DDR: Attempting to dial 82489522

00:02:42: Vi3 DDR: Unable to dial 82489522.

00:02:43: Di1: No free dialer - starting fast idle timer

There is no modem activity (no tx/rx lights).

I don't understand the dialer1 entry.

My understanding of all of the example Cisco configs is

that "backup interface async1" on interface atm0 tells Dial

Backup to use interface async1 (AUX0?). Interface async1

is configured as "dialer pool-member 2" which I think refers

to interface dialer2 (which contains "dialer pool 2").

Can you shed any light on this?

Thanks once again

Richard

Bronze

Re: Soho 97 Dial Backup fails

Hi

The dialing cause is an ip packet (s=61.8.4.81, d=61.8.0.2). This packet will be

forwarded to dialer 1 because the default route is pointing to Dialer 1.

The dialer-group 1 command refers to the dialer-list in which you define what is interesting traffic to place a call.

With the dialer pool 1 command you define where to place the call. In your case you have either to adapt this to dialer pool 2 or to use the dialer interface 2 in which case you have to define the default route pointing to dialer 2.

Hope that helps

Roger

198
Views
0
Helpful
3
Replies
This widget could not be displayed.