Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

some 2950 switch ports led turn amber even without cable connection

Hello. Due to a likely NIC problem, after connecting my laptop to a port on the 2950 switch, the led turns amber even after disconnecting the cable.

2 ports on the switch are having this problems. Ideally the led should be off when nothing is connected.

Please, how can I correct this problem without restarting the switch because its in a production environment.

Eddy

10 REPLIES

Re: some 2950 switch ports led turn amber even without cable con

Hello,

which two switchports are amber? Try toggling the port LED modes by pressing the mode button.

Have a look at

http://www.cisco.com/en/US/products/hw/switches/ps628/products_installation_guide_chapter09186a008007e889.html#xtocid41699

for the different port modes meanings and their respective usage of port LEDs.

It would also be helpful to see the port status from the switch CLI in case the procedure above didn´t solve the problem.

Hope this helps

Martin

New Member

Re: some 2950 switch ports led turn amber even without cable con

Thanks for ur prompt reply.

It was ports 12 and 17. These were free before I connected the laptop to port 17. After disconnecting the cable the LED remained. I tried to connect to the other free port 12 and got the same.

Since then it has remained dat way without any cable connection

Re: some 2950 switch ports led turn amber even without cable con

Hello,

and toggling the port mode (press the mode button) did not change anything?

Martin

New Member

Re: some 2950 switch ports led turn amber even without cable con

Thanks.

Not at all. The status mode still shows the LED on the ports amber without any cable connection.

From the link u sent to me:

Port is not forwarding. Port was disabled by management or an address violation, or it was blocked by Spanning Tree Protocol (STP).

Please how do I resolve this? I never disabled any port may be the laptop did

Eddy

VIP Purple

Re: some 2950 switch ports led turn amber even without cable con

Hello Eddy,

make sure the ports are configured like this:

interface FastEthernet0/2

switchport mode access vlan X

spanning-tree portfast

The ports might simply be broken, can you post the output of ´show controllers interface FastEthernet´ of the ports that do not function properly ?

Regards,

GP

VIP Purple

Re: some 2950 switch ports led turn amber even without cable con

Eddy,

one more thing, try to configure:

errdisable recovery cause all interval 30

on the switchports in question. This will reacivate the ports within 30 seconds...

Regards,

GP

Purple

Re: some 2950 switch ports led turn amber even without cable con

Do a show interface status and you'll probably see that they are in a "errdisable state" , just go into the interface and do a shut , then no shut and this will probably clear it .

New Member

Re: some 2950 switch ports led turn amber even without cable con

Thanks a lot. It works. But please how do i prevent this?

Eddy

VIP Purple

Re: some 2950 switch ports led turn amber even without cable con

Hello,

check the switch log for any entries regarding the reason why the port was shut down. Also, can you post the configuration of your port and/or switch ?

Regards,

GP

New Member

Re: some 2950 switch ports led turn amber even without cable con

You may also want to check any port security options that may be enabled. Depending on the violation mode configured (protect, restrict, shutdown) you may have triggered a violation thus forcing the port into errdisable state.

You can check for port-security violations by issuing the command 'sh port-security '.

Port security is not enabled by default if it is you will see something like this configured on the interface(s).

switch(config-if)#switchport port-security

switch(config-if)#switchport port-security violation {protect | restrict | shutdown}

1326
Views
0
Helpful
10
Replies
CreatePlease to create content