Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

spanning-tree portfast

WS-2950G-48-EI switch

All 48 of the 10/100 ports have portfast enabled. I have a dlink dss-8+ switch conencted to one of the port. 2 of my win xp pro workstations are connected to the dlink switch. When I first start up the workstations and log in to the domain, it takes about a min or 2 before I get to the desktop. It takes forever at the applying your computer settings and applying your personal settings screen. I disabled portfast on the port of the cisco switch whitch the dlink is connected to. Same thing.

When I plug my workstation directly into the cisco switch (with or without portfast enable), it's fine.

Any ideas?

4 REPLIES
Green

Re: spanning-tree portfast

You probably need to disable spanning-tree copletely, since the D-Link (probably) doesn't support it.

Portfast still uses spanning-tree, it just makes some assupmtions to permit faster media access.

Good Luck

Scott

Hall of Fame Super Bronze

Re: spanning-tree portfast

You may have a faulty DLink switch. I've connected 3rd party switches (LinkSys, NetGear, Dlink, among others) to Cisco switches with or without Spanning-Tree Portfast and I've never seen this problem.

Do you have another 3rd party switch around and test ?

Purple

Re: spanning-tree portfast

Check to make sure you don't have speed/duplex mismatches , if the Dlink doesn't support hardcoding then the cisco switch must be set as auto/auto for speed and duplex.

New Member

Re: spanning-tree portfast

Hi!

i faced like this issue before;it was from DHCP SERVER;Try theire maybe it will from the DHCP Scope

10xs

459
Views
0
Helpful
4
Replies
CreatePlease login to create content