Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

spanning tree problem - BPDU's

hi,

Have a look at attachment,there is a 2950 24 port switch , which is connected to 8274 ibm core switch via ethernet.The 2950 has two fibre modules connected to 4507 switch with hsrp and etherchannel configured.

The 2950 switch ethernet link connected to 8274 ibm core switch is

fluctuating. at rare cases the ethernet led truns amber and link goes down for few seconds.

On observing the 2950 switch, it was found that there is no issue

with the hardware , It is a BPDU problem , where BPDU packets are

being generated by both data centre switch and IBM core switch. Any

one of the BPDU has to be blocked inorder to avoid the link failure.

The following commands were tested in the cisco 2950 switch .

1. Spanning-tree Port fast has been enabled.(for testing purpose)

2. Spanning-tree portfast bpdufilter default.

3. Making fastethernet 0/1 as trunklink.

4. Changing Spanningtree priority value.

5. Enabling Spanningtree gaurd root.

Note :

====

The Ethernet port of 8274 IBM core switch connecting 2950 switch has to be

made as trunk, since it is an uplink to 2950 switch..it is not yet checked as we dont have access to ibm switch.

it is sure that only configuration changes has to be done at 2950 side, since hardware has been replaced last before week and old conf is missing, earlier it was working setup.

i have pasted the error message,configuration details of 2950 switch.

Error message

=============

interface GigabitEthernet0/1

--More--

1w3d: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk

FastEther

net0/1 VLAN1.

1w3d: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/1 on VLAN0001.

Inconsi

stent port type.

1w3d: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/1 on

VLAN0001.

Port consistency switchport mode trunk

regards

Babu

3 REPLIES
Community Member

Re: spanning tree problem - BPDU's

configuration of 2950 switch.

Switch#sh run

Building configuration...

Current configuration : 1658 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

ip subnet-zero

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface GigabitEthernet0/1

switchport mode trunk

no ip address

!

interface GigabitEthernet0/2

switchport mode trunk

no ip address

!

interface Vlan1

no ip address

no ip route-cache

no shutdown

!

ip default-gateway 192.168.27.244

ip http server

!

!

line con 0

line vty 0

password cisco

login

line vty 1 4

login

line vty 5 15

!

end

========================================================

Switch# sh int fa0/1

FastEthernet0/1 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 000d.bce2.d981 (bia 000d.bce2.d981)

MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute ouxtput rate 0 bits/sec, 0 packets/sec

22080908 packets input, 3195162754 bytes, 0 no buffer

Received 14136375 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ig

=========================================

Silver

Re: spanning tree problem - BPDU's

Hi Babu,

Just go thro. the following link explaining various reasons for link fluctuation due to stp inconsistencies,

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00801d11a0.shtml

I think your ibm switch port may be in 802.1Q trunk mode. Pls. chk. If else, see you case come under which category in that link.

Hope it will help

Re: spanning tree problem - BPDU's

Error Message: SPANTREE-7-RECV-1Q-NON-TRUNK: Received 802.1Q BPDU on non trunk

[chars] [chars].

Note: This message applies to Catalyst 3550, 2955, 2950, and 2940 switches.

Explanation: An SSTP bridge protocol data units (BPDU) was received on the listed interface, which is not an operational trunking interface. The first [chars] is the port name, and the second [chars] is the VLAN name.

Recommended Action: Verify that the configuration and operational state of the listed interface and that of the interface to which it is connected are in the same mode (access or trunk). If the mode is trunk, verify that both interfaces have the same encapsulation (none, ISL, or 802.1Q). When these parameters are consistent, spanning tree automatically unblocks the interface.

Looks like the IBM is sending DTP in which the fa0/1 becomes trunk and switch unblock the port and removes the inconsistency. Follow the recommendation above.

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2950/12122ea7/smg/msg_desc.htm

2644
Views
0
Helpful
3
Replies
CreatePlease to create content