Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Spanning Tree Root Port

My understanding of MSTP and STP in general is that if a switch has two equal paths (read same port priority and path cost) the port with the lower interface number forwards and the port with the higher interface number blocks.

Here's the layout: 1 Catalyst 6513 at the core and a stack of 3 Catalyst 3550s at the edge. The top 3550 connects to the core via gig fiber on int g0/1; the bottom 3550 connects to the core via gig fiber on int g0/2; the middle 3550 connects to the top and bottom 3550s via gig copper on int g0/1 and g0/2.

I've spot checked approximately 20 stacks in this configuration, and the middle switch was always blocking int g0/2. Today, however, I've got one switch that insists on blocking int g0/1...even if the port priority of g0/1 is set to 0 or 16. The only way I can get it to forward is by changing the path cost. Am I missing something basic here? Is this a bug in IOS 12.1(13)EA1a?

For what it's worth, I took the 6513 out of the picture and placed another 3550 in its place, set the new 3550 as the root bridge...yielded same results.

Thanks in advance for any help or advice.

2 REPLIES
Gold

Re: Spanning Tree Root Port

Assumption #1: the 6513 is the Root Bridge for all VLANs.

Assumption #2: in the stack in question, the middle 3550's Gig0/1 interface is connected to the top 3550's Gig0/2 interface.

Question: Do you have UplinkFast enabled on the top 3550, and disabled on the bottom 3550?

The reason why I ask is, that the UplinkFast feature changes STP-related settings in two ways:

1. It sets the Bridge Priority of a switch to a high value (49152), which almost always keeps the switch from becoming Root Bridge for any VLAN; and

2. It adds 3000 to the path costs of all ports and VLAN trunks on the switch, which makes the switch less attractive as a pathway to the Root Bridge for any VLAN.

If you have UplinkFast enabled on the top 3550 and not on the bottom 3550, then the middle 3550 should block interface Gig0/1 and favor Gig0/2, because it costs less to go through the bottom 3550 to reach the Root Bridge.

Hope this helps.

New Member

Re: Spanning Tree Root Port

Yes, the 6513 is the root bridge for all VLANs. And yes, the top g0/2 is connected to the middle g0/1, the middle g0/2 is connected to the bottom g0/1. Uplinkfast is not enabled. All 3550s are configured identically (less hostname, IP, etc.) as follows:

!

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xxxxxxxxxxxxx

!

aaa new-model

aaa authentication login default group tacacs+ line

aaa authentication login console line

aaa authorization exec default group tacacs+ if-authenticated

aaa authorization network default group tacacs+

enable secret xxxxxxxxxxxxx

!

clock timezone CST -6

clock summer-time CST recurring

ip subnet-zero

no ip domain-lookup

!

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos min-reserve 5 170

mls qos min-reserve 6 10

mls qos min-reserve 7 65

mls qos min-reserve 8 26

mls qos

udld aggressive

!

!

spanning-tree mode mst

spanning-tree extend system-id

spanning-tree backbonefast

!

spanning-tree mst configuration

name xxxxxx

revision 2

instance 1 vlan 1-4094

!

!

!

interface FastEthernet0/1

switchport access vlan 124

switchport mode dynamic desirable

switchport trunk encapsulation dot1q

switchport trunk native vlan 124

switchport voice vlan 201

no ip address

mls qos trust device cisco-phone

mls qos trust cos

storm-control broadcast level 75.00

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

!

!

!All FastEthernet interfaces configured the same

!

!

interface FastEthernet0/24

switchport access vlan 124

switchport mode dynamic desirable

switchport trunk encapsulation dot1q

switchport trunk native vlan 124

switchport voice vlan 201

no ip address

mls qos trust device cisco-phone

mls qos trust cos

storm-control broadcast level 75.00

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

mls qos trust cos

udld port aggressive

storm-control broadcast level 75.00

auto qos voip trust

wrr-queue bandwidth 20 1 80 1

wrr-queue queue-limit 80 1 20 1

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

mls qos trust cos

udld port aggressive

storm-control broadcast level 75.00

auto qos voip trust

wrr-queue bandwidth 20 1 80 1

wrr-queue queue-limit 80 1 20 1

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

!

interface Vlan1

no ip address

shutdown

!

interface Vlan124

ip address 10.xxx.xxx.x 255.255.254.0

!

ip default-gateway 10.xxx.xxx.1

ip classless

no ip http server

!

!

logging 10.xxx.xxx.xxx

access-list 10 permit 10.xxx.xxx.0 0.0.15.255

snmp-server community xxxxxxxxx RW

snmp-server chassis-id xxxxxxxxxx

snmp-server host 10.xxx.xxx.xxx xxxxxxx envmon syslog snmp

tacacs-server host 10.xxx.xxx.xxx key xxxxxxxxx

!

line con 0

password xxxxxxxxx

logging synchronous

login authentication console

line vty 0 4

access-class 10 in

password xxxxxxxxx

logging synchronous

login authentication default

line vty 5 15

access-class 10 in

password xxxxxxxxx

logging synchronous

login authentication default

!

ntp server 10.xxx.xxx.xxx

!

end

Here is the output from a show spantree detail:

MST00 is executing the mstp compatible Spanning Tree protocol

Bridge Identifier has priority 32768, sysid 0, address 000b.be3d.7a80

Configured hello time 2, max age 20, forward delay 15

Current root has priority 24576, address 000b.4522.45c0

Root port is 26 (GigabitEthernet0/2), cost of root path is 0

Topology change flag not set, detected flag not set

Number of topology changes 2 last change occurred 00:01:13 ago

from GigabitEthernet0/2

Times: hold 1, topology change 35, notification 2

hello 2, max age 20, forward delay 15

Timers: hello 0, topology change 0, notification 0

Port 25 (GigabitEthernet0/1) of MST00 is alternate blocking

Port path cost 20000, Port priority 128, Port Identifier 128.25.

Designated root has priority 24576, address 000b.4522.45c0

Designated bridge has priority 32768, address 000b.bea4.9f00

Designated port id is 128.26, designated path cost 0

Timers: message age 4, forward delay 0, hold 0

Number of transitions to forwarding state: 0

Link type is point-to-point by default, Internal

BPDU: sent 13, received 45

Port 26 (GigabitEthernet0/2) of MST00 is root forwarding

Port path cost 20000, Port priority 128, Port Identifier 128.26.

Designated root has priority 24576, address 000b.4522.45c0

Designated bridge has priority 32768, address 000b.bea3.b280

Designated port id is 128.25, designated path cost 0

Timers: message age 4, forward delay 0, hold 0

Number of transitions to forwarding state: 0

Link type is point-to-point by default, Internal

BPDU: sent 13, received 43

MST01 is executing the mstp compatible Spanning Tree protocol

Bridge Identifier has priority 32768, sysid 1, address 000b.be3d.7a80

Configured hello time 2, max age 20, forward delay 15

Current root has priority 24577, address 000b.4522.45c0

Root port is 26 (GigabitEthernet0/2), cost of root path is 40000

Topology change flag not set, detected flag not set

Number of topology changes 5 last change occurred 00:01:17 ago

from GigabitEthernet0/2

Times: hold 1, topology change 35, notification 2

hello 2, max age 20, forward delay 15

Timers: hello 0, topology change 0, notification 0

Port 25 (GigabitEthernet0/1) of MST01 is alternate blocking

Port path cost 20000, Port priority 128, Port Identifier 128.25.

Designated root has priority 24577, address 000b.4522.45c0

Designated bridge has priority 32769, address 000b.bea4.9f00

Designated port id is 128.26, designated path cost 20000

Timers: message age 4, forward delay 0, hold 0

Number of transitions to forwarding state: 1

Link type is point-to-point by default, Internal

BPDU: sent 13, received 47

Port 26 (GigabitEthernet0/2) of MST01 is root forwarding

Port path cost 20000, Port priority 128, Port Identifier 128.26.

Designated root has priority 24577, address 000b.4522.45c0

Designated bridge has priority 32769, address 000b.bea3.b280

Designated port id is 128.25, designated path cost 20000

Timers: message age 4, forward delay 0, hold 0

Number of transitions to forwarding state: 2

Link type is point-to-point by default, Internal

BPDU: sent 13, received 45

Thanks for any help or suggestions.

205
Views
0
Helpful
2
Replies