Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Speed Issue

I have four 3550 Switches for Lan and one 2600 Router which is connected to an ISP. All the Switches are having Gig ports and are interconnected using Fiber. So, all the switches will be communicating at 1000 mbps. I am little bit confused while connecting the Switch with the Router. Since my Router is not having Gig Port and have only FastEthernet port.

Still I am in design phase, I have planned s to connect the switch with the router using an ordinary FastEthernet port, say fe0/1 of the Switch. But, I am not sure whether this will work or not since, the traffic between the Lan Switches will be flowing at a speed of 1000 mbps and between the Router and Switch it will be 100 mbps.

If any of you guys have any other solutions plz suggest me. Thanks in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Purple

Re: Speed Issue

Hi Rajesh,

The fact that the link between your router and the switch is 100 Mbps is not a problem at all. LAN links tend to be much faster than WAN links in general. Also, how big is your Internet link going to be ? If it is greater than 100Mbps (which I am thinking is not very likely), the 100Mbps router link to your switch is not going to be an issue. The bottleneck is, after all, your Internet link.

If, however, you have a link to the Internet that is greater than 100Mbps, then you certainly want a GigE link between your router and switch.

The fast (GigE) LAN links will allow your client PCs to access your server PC at high speeds.

Now, just because your hosts may be connected to your LAN switches with GigE links does not mean that your Internet downloads will be that fast. Most of your Internet traffic is likely to be downstream and will be limited to the size of your Internet link.

So, in a nutshell, what you are proposing is perfectly fine.

Hope that helps - pls rate the post if it does.

Regards,

Paresh.

VIP Purple

Re: Speed Issue

Hello,

in addition to the other posts, make sure that the ports connecting your switch and your router are set to fixed duplex and speed settings:

3550

!

interface FastEthernet0/1

speed 100

duplex full

2600

!

interface FastEthernet0/1

speed 100

duplex full

Regards,

GP

6 REPLIES
Purple

Re: Speed Issue

Hi Rajesh,

The fact that the link between your router and the switch is 100 Mbps is not a problem at all. LAN links tend to be much faster than WAN links in general. Also, how big is your Internet link going to be ? If it is greater than 100Mbps (which I am thinking is not very likely), the 100Mbps router link to your switch is not going to be an issue. The bottleneck is, after all, your Internet link.

If, however, you have a link to the Internet that is greater than 100Mbps, then you certainly want a GigE link between your router and switch.

The fast (GigE) LAN links will allow your client PCs to access your server PC at high speeds.

Now, just because your hosts may be connected to your LAN switches with GigE links does not mean that your Internet downloads will be that fast. Most of your Internet traffic is likely to be downstream and will be limited to the size of your Internet link.

So, in a nutshell, what you are proposing is perfectly fine.

Hope that helps - pls rate the post if it does.

Regards,

Paresh.

New Member

Re: Speed Issue

Thanks,

If i going to connect one of my FastEthernet port as the uplink port to router, say Fe 0/2 then should i need to mention this as a trunk link ?? like

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

no shut

or just leave Fe 0/2 as if without any configs like

interface FastEthernet0/2

!

Thanks in Advance.

Purple

Re: Speed Issue

Hi Rajesh,

That depends on whether you are also intending to use the router for inter-vlan routing. If you are using it for inter-vlan routing, you have to certainly configure it as a trunk port.

However, if you are only going to use if for your Internet traffic, then there is no need to configure it as a trunk; leaving it as an access port will suffice.

Hope that helps - pls rate the post if it does.

Regards,

Paresh.

New Member

Re: Speed Issue

Oops !!! Before that sorry to mention that, all the inter Vlan stuffs will be carried by one of the L3 3550 switch which is found in the Lan.

Also need to know...should i need to do any configuration in router's FastEthernet except the ip addressing like

interface FastEthernet0/0

ip address 192.168.13.250 255.255.255.0

no shut.

Thanks

Re: Speed Issue

Hi Rajesh,

If your inter vlan is been done by 3550 switch then you need not configure trunk for your router connection.

Just make sure your are able to ping your router ethernet port from all your machines which belong to different vlans which will confirm that intervlan routing on your 3550 is working fine and all your machines which belong to different vlans are able to route and reach your router.

On your router your config will only have IP address for that port and your switch port connecting to router will belong to just an access vlan (whatever vlan you want) and for same vlan you will be having a logical interface on 3550 with same subnet ip which you have on router ethernet interface for routing.

HTH

Ankur

VIP Purple

Re: Speed Issue

Hello,

in addition to the other posts, make sure that the ports connecting your switch and your router are set to fixed duplex and speed settings:

3550

!

interface FastEthernet0/1

speed 100

duplex full

2600

!

interface FastEthernet0/1

speed 100

duplex full

Regards,

GP

97
Views
0
Helpful
6
Replies