Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mx
Community Member

SSH on a 4948

Hi. I cant seem to get ssh configured on a 4948 switch at all. Am I missing something? The docs says it supports it but I dont even have transport ssh as an option, nor can I generate a key.

thanks for any tips!

bob

1 ACCEPTED SOLUTION

Accepted Solutions
Blue

Re: SSH on a 4948

you need IOS version 12.3(7)JA and up for SSH v2 server & client. (which contains SSH v1 as well)

you could either have an incorrect IOS or a buggy one. upgrade if you can to a later IOS.

if the IOS is simply incorrect, please use the feature navigator to find the features your 4948 supports with which IOS version:

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

3 REPLIES
Blue

Re: SSH on a 4948

you need IOS version 12.3(7)JA and up for SSH v2 server & client. (which contains SSH v1 as well)

you could either have an incorrect IOS or a buggy one. upgrade if you can to a later IOS.

if the IOS is simply incorrect, please use the feature navigator to find the features your 4948 supports with which IOS version:

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

mx
Community Member

Re: SSH on a 4948

AHA! Mystery solved, thank you. Yes, I have 12.2.x on it right now. I will upgrade.

thank you much!

bob

Re: SSH on a 4948

I think you will find that there isn't currently a 12.3x release for the Catalyst 4948......... The latest release for these switches is 12.2(31)SG.

What you actually need is the Crypto image. There are actually 4 versions (feature sets) of the 4948 IOS images - IP Base without Crypto, IP Base SSH, Enterprise Services without SSH and Enterprise Services SSH. The packaging names have changed a bit (Enhanced L3, Basic L3 etc) but there have been 4 feature sets for this platform (Catalyst 4500 series) for a while.

You need CCO Crypto privileges to download the Crypto images I think.

HTH

Andy

263
Views
6
Helpful
3
Replies
CreatePlease to create content