Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Standard Configuration Reqd to improve Switch/LAN performance

Hello Friends,

I have Six Catalyst 2955 Switches on which RSTP is running (Just "spanning-tree mode rapid-pvst" runs)...now I want to ask what are the other standard things (like IGMP snooping etc) needed to configure switches to improve performance (no need to improve security)..I have only 20 PCs LAN connected to these Six Switches.

Pls. help me....I will really appreciate.

Regards,

Shahid

3 REPLIES
New Member

Re: Standard Configuration Reqd to improve Switch/LAN performanc

You can activate portfast on all user interfaces (not on trunks) to skip some spanning tree phases when equipment is connected.

"interf range fa 0/1 - 12"

"spanning-tree portfast"

Sending cdp messages to the user ports is also unnecessary :

"interf range fa 0/1 - 12"

"no cdp enable"

These settings should not greatly improve the performance, but any little thing helps.

Paul De Valck

New Member

Re: Standard Configuration Reqd to improve Switch/LAN performanc

Thanks for the answer...

Actually, I want standard configuration (other than STP) for ease of management, improve performance...I mean basic switch configuration...

shahid

New Member

Re: Standard Configuration Reqd to improve Switch/LAN performanc

Shahid,

hereby an example of a (similar) configuration of a L2 switch.

Maybe it can act as an example

Paul De Valck

----------------------------------------------

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname

!

enable secret

!

! Summertime definition (Brussels)

!

clock timezone CET 1

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00

!

! automatic restart of ports after a port error

!

errdisable recovery cause all

errdisable recovery interval 180

!

ip subnet-zero

!

vtp mode trans

vlan 4

name Admininstrative_VLAN

exit

!

no ip domain-lookup

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

interface Vlan4

descr Aministrative VLAN for switch management

ip address 10.40.2.251 255.255.255.248

no ip route-cache

no shut

!

ip default-gateway 10.40.2.254

ip http server

!

logging history size 50

!

! syslog servers

!

logging 10.32.1.40

logging 10.192.1.40

!

! limit snmp access

!

access-list 1 permit 10.40.0.0 0.0.3.255

access-list 1 permit 10.192.1.32 0.0.0.31

access-list 1 permit 172.31.0.0 255.255.0.0

!

! snmp access

!

snmp-server community

snmp-server community RW 1

snmp-server queue-length 100

snmp-server location Brussels Main Office

!

! SNMP traps

!

snmp-server enable traps

snmp-server host 10.192.1.38

snmp-server host 10.32.1.38

!

! Console & Telnet login

!

line con 0

session-timeout 10

exec-timeout 7 0

password

login

line vty 0 15

session-timeout 10

exec-timeout 7 0

password

login

!

! time synchronisation with ntp server

!

ntp server 10.32.1.38 prefer

ntp server 10.192.1.38

end

207
Views
0
Helpful
3
Replies