Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

static and dynamic NAT with one IP on 2621 router

I want to use an 2621 router (IOS 12.2) for an DSL connection with one usable static IP.

I setup an NAT, with one public IP and an internal privat network.

It is possible to use one IP for:

* The router's ip

* static NAT for one Port i.e webserver, ftp server

* NAT for clients of the inside interface

Thank you,

Raik

  • Other Network Infrastructure Subjects
3 REPLIES
New Member

Re: static and dynamic NAT with one IP on 2621 router

You'll want to do something like:

interface e0

ip address 204.1.1.1 255.255.255.0

ip nat outside

!

interface e1

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

ip nat inside source list 1 interface ethernet 0 overload extendable

ip nat inside source static tcp 192.168.1.2 80 204.1.1.1 80 extendable

ip nat inside source static tcp 192.168.1.2 25 204.1.1.1 25 extendable

access-list 1 permit 192.168.1.0 0.0.0.255

You may want to look into the exact use of extendable, but I seem to remember needing it for this.

Mick.

New Member

Re: static and dynamic NAT with one IP on 2621 router

Use Cisco ConfigMaker. You can do this in the GUI and then check out the syntax in the CLI..

New Member

Re: static and dynamic NAT with one IP on 2621 router

Thank you I got it to work.

313
Views
0
Helpful
3
Replies
This widget could not be displayed.