Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

STATIC NAT

Hi,

I am facing a problem in static nat. I am having a 1760 router with 12.3(6) version of ios. i have configured a static nat using the command

Ip nat inside source static x.x.x b.b.b.b

All of a sudden the nat was not happening. i have enabled the debug ip nat detailed command. and found out that the ip is getting natted.But i was not able to see any return traffic coming to the natted ip.

But if i use a PAT (e.g) ip nat inside source list 1 serial0/0 overload command nat is working fine without any problem.

If i use a nat pool also it is not working. Only overload option is working.

What could be the reason for this behavior. How do we solve this.

Krishna.

4 REPLIES
VIP Purple

Re: STATIC NAT

Hello,

what addresses are you using as static and in your pool ? Can you post the config of your router, as well as the addresses you are using during static and pool address translation ?

Regards,

GP

New Member

Re: STATIC NAT

HI,

I am using a public address in my nat pool.

i am using two nat statement.

ip nat inside source static 192.168.10.15 x.x.x.y

ip nat inside source static 192.168.10.20 x.x.x.z

where x.x.x.y and x.x.x.z is the public address

int fa0/0

ip address 192.168.10.1 255.255.255.0

ip nat inside

int fa0/1

description **** connected to isp ******

ip address x.x.x.u 255.255.255.248

ip nat ouside

Regards

Krishna.

VIP Purple

Re: STATIC NAT

Hello Krishna,

your config looks ok. Did the static and pool NAT actually ever work ? I wonder if the problem might be with your ISP. There is a previous post from a few days ago, where somebody had almost exactly the same problem as you. Eventually, it turned out that the ISP was not properly routing the assigned public IP address space. Can you check that with your provider ?

Regards,

GP

New Member

Re: STATIC NAT

Hi GP,

We had checked with the ISP. they are sayig that no problem in there side. anyway i will have a word with them once again.

We thought of creating a loopback interface for those two public and configuring it for nat.

regards

Krishna.

108
Views
0
Helpful
4
Replies