Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

static route and eigrp two questions

first:

I use static float route to use backup interface,and destination are two net: 21.0.0.0,22.0.0.0 but when master interface serial down ,only the net 21.0.0.0 next hop chage to backup interface and net 22.0.0.0 still use default next hop (the master interface,even it is down),why? it is so strange!

config is below:

interface Serial5/0

ip address 22.52.127.6 255.255.255.252

ip access-group 144 in

ip access-group 144 out

encapsulation ppp

!

ip route 21.52.64.0 255.255.224.0 22.52.124.25 80

ip route 21.52.64.0 255.255.255.0 21.52.127.5

ip route 22.52.64.0 255.255.224.0 22.52.124.25 80

ip route 22.52.64.0 255.255.255.0 21.52.127.5

#show ip interface brief

Serial5/0 22.52.127.6 YES NVRAM down down

#show ip route

S 21.52.64.0/19 [80/0] via 22.52.124.25

S 22.52.64.0/19 [1/0] via 21.52.124.5

#show version

IOS (tm) 7200 Software (C7200-JS-M), Version 12.1(20)E, EARLY DEPLOYMENT RELEASE

SOFTWARE (fc1)

The strange happened in all my wan interface! and I have another 7206 with different IOS at work online too,and even have the trouble!!!

second:same router and same config, i use eigrp too, but when i use no auto-summary config why still a summary address in route table???

#show running-config

router eigrp 1

network 21.0.0.0

network 22.0.0.0

network 23.0.0.0

no auto-summary

eigrp log-neighbor-changes

no eigrp log-neighbor-warnings

#show ip route

D 21.52.0.0/17 is a summary, 21:55:13, Null0

any suggest is thankful!!

DAVID

1 REPLY
Cisco Employee

Re: static route and eigrp two questions

1)

It is not so strange. Your static route only specifies a next hop. As long as the next hop for that static route (in this case 21.52.127.5) is resolvable , either via a directly connected route or via any other route, the static route will remain in the routing table.

If you want to make sure that the static route is removed after the interface goes down, use the following syntax:

ip route 21.52.64.0 255.255.255.0 se5/0

ip route 22.52.64.0 255.255.255.0 se5/0

2) The summary installed by Eigrp in the routing table is not due to auto summarization (not on majornet boundary) but to manual summarization. Check your configuration for the following statement on one of the interfaces on this router:

ip summary-address eigrp 1 21.52.0.0 255.255.128.0 5

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
164
Views
0
Helpful
1
Replies
CreatePlease to create content