Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

STP Issues

Hi guys...

Can any one suggest me how to check STP is working properly or not.

I used "Show ip interface brief" all the interfaces ware up. The I used "show spanning-tree active". In the role, it showed me as Root, Desig, Altn etc.....

In every place i saw only FWD under Status. So, iam little bit confused. Can any one suggest me how to check STP is working or not.

Thanks

Rajesh

2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Re: STP Issues

I took a look at your network diagram. I would recommend removing the red cable. You will still have redundancy without it and it will really only make your STP topology more complicated than it needs to be.

To see if STP is working properly use the "sh spanning-tree int gx/x" command. What you should see is that all ports in the core are forwarding. On the edge switches both uplinks to the core are forwarding and one of the edge switches will put the link between the switches into a bloking state.

-Mark

Re: STP Issues

The links between your access switches should have one end alternate blocking (on either side).

You can issue the command "show span blockedport" on the access switch to identify them. But the simplest is, as you did, to do a simple "sho span vlan 4". Also, I guess than your uplinks are not a in the range fa0/1-24 on the access switches, else you would have a portfast issue that could open (in theory) temporary bridging loops.

BTW, you have a global command that allows you to enable portfast on all ports by default on an access switch: "span portfast default". Then, on your uplinks you explicitly disable portfast using "span portfast dis".

Regards,

Francois

6 REPLIES

Re: STP Issues

Hi,

make sure you have redundant L2 pathes, f.e. two parallel trunks between two L2 switches. One of the ports should then be blocking. Otherwise you will see broadcasts and unknown frames circling and getting a huge load on the links (assuming some broadcast/unknown MAC traffic across your switches).

STP is not applicable in a L3 environment and also FWD will be seen on all ports in case you build a tree-like topology, i.e. only one link per access switch to one core (root).

Hope this helps

Martin

New Member

Re: STP Issues

Hi Martin,

I have attached my topology diagram. You can see 4 parallel link as trunk to the core and all 2950's are interconnected for redundency.

In the core, i lowered the priority by assigning

spanning-tree mode rapid-pvst

spanning-tree extend system-id

spanning-tree vlan 1 priority 24576

spanning-tree vlan 2 priority 24576

spanning-tree vlan 3 priority 24576

spanning-tree vlan 4 priority 24576

In all the access switch i configured,

interface range fastethernet 0/1 - 24

switchport mode access

switchport access vlan 4

spanning-tree portfast

no shut

exit

Vlan 1,2,3 & 4 ware created in core and respective ports are assigned in core switches. Intervlan is working fine even after applying STP commands.

In order to make sure whether every thing is right, i used the command show ip interface brief for all the access layer switches, all the trunk ports are shown Up Up.

Plz suggest me how to check which port got blocked, if i d't find any blocked ports is there any other command i need to add in the core or access switches. Your suggestions will be of great help.

Thanks

New Member

Re: STP Issues

I took a look at your network diagram. I would recommend removing the red cable. You will still have redundancy without it and it will really only make your STP topology more complicated than it needs to be.

To see if STP is working properly use the "sh spanning-tree int gx/x" command. What you should see is that all ports in the core are forwarding. On the edge switches both uplinks to the core are forwarding and one of the edge switches will put the link between the switches into a bloking state.

-Mark

New Member

Re: STP Issues

Hi Mark..

Now i learnt things better in STP and its working. As you said, if i remove the extra red link between switch 2 & 3(refer diagram) the STP is perfect and one of the port is blocked. If i add the Red cross over link, only the red trunk is blocked and the rest are in forwarding state.

Just out of curiosity i am asking, how can be fixed. But its not a big issue.

Any how thanks guys...i have successfully completed the project.

Regards

Rajesh

Re: STP Issues

The links between your access switches should have one end alternate blocking (on either side).

You can issue the command "show span blockedport" on the access switch to identify them. But the simplest is, as you did, to do a simple "sho span vlan 4". Also, I guess than your uplinks are not a in the range fa0/1-24 on the access switches, else you would have a portfast issue that could open (in theory) temporary bridging loops.

BTW, you have a global command that allows you to enable portfast on all ports by default on an access switch: "span portfast default". Then, on your uplinks you explicitly disable portfast using "span portfast dis".

Regards,

Francois

New Member

Re: STP Issues

Hi, you may want to use the lowest priority in the core. Something like 100. Some switches will not allow this value and you will have to use 4096. This just prevents any other switches added to the network from becoming the root for that vlan.

116
Views
0
Helpful
6
Replies
CreatePlease to create content