Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

string modemcap sportster 56K

Hi, Anybody have a idea of a good string to connect 2 routers with dial in serial async, using a external modem USR 56K.

I has been any problems with a simple stuff, connect routers with dial on demand.

In debug ppp negotiation I can see many REQSENT and only OUTPUT and router called.

I tried many strings with a technical manual of modem, but until now, I failure with all.

ANy help is very important..

thanx.,

8 REPLIES
Cisco Employee

Re: string modemcap sportster 56K

Here is the url which has modem init strings for various modem models.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios112/112cg_cr/3rbook/3rappmdm.htm

Silver

Re: string modemcap sportster 56K

AT&F1S0=1&C1&D2&A1&W should work fine...with dip switches 3& 8 down, rest up.

Thanks, Mak.

New Member

Re: string modemcap sportster 56K

Ok Max, your string help me so much.

But I only achieve make the connection works a 19200bps, higher speeds, the negotiation of PPP stay in loop, and it don't close (REQSENT)

Ok, but now there are a funny stuff, The connection was estabilished, but don't traffic none information (E.g: The ping failed, but the connection is up!!)

Whats can be happened?? I tried all ( I think).

Thanks....

Silver

Re: string modemcap sportster 56K

If you have very less traffic on the router (or during maintenance period) can try to ping the peer & capture "deb ip packet detail" on both ends.. or can use an access list to debug ip packets.

Will need to see running configs on both router & the debugs.

Thanks, Mak.

Bronze

Re: string modemcap sportster 56K

The connection is "UP" but it might be "spoofing".

I suggest that you enter the strings directly to the USR modem

and save it, using reverse telnet. Try using the following strings:

AT&F1S0=1&C1&D3&W

(Note: &W is important because it saves the modem config)

Verify your modem config using &i4 (display current modem settings)

(Use &$ for help options)

then close your reverse telnet session.

Try using the following commands under the line you are

using for the async interface: (I've used AUX 0 for example)

line aux 0

modem inout

transport input all

stopbits 1

flowcontrol hardware

modem autoconfigure discovery

autoselect ppp

We have done this many times using USR Courier and Sportster modems

with successful high speed connection (usually 48K and above).

But take note that if the phone line you are using passes through

a PBX, meaning outside line access is required (e.g., dial '0'),

you might only get a max of 33.6K connection.

Hope this helps.

New Member

Re: string modemcap sportster 56K

Ok Mak, its string was very important, and it helped me very. After some tests, I moved in line 2 the type of modem, instead of modem autoconfigure discovery I placed modem autoconfigure type to usr_sportster, and finally the connection functioned perfectly. I thank its aid very.

Thank you..

New Member

Re: string modemcap sportster 56K

My name is Daniel and I'm helping rsoave.

We called the 2 routers Local e Remoto.

The debug's :

Remoto#ping 140.40.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 140.40.1.1, timeout is 2 seconds:

00:18:53: IP: s=140.40.1.2 (local), d=140.40.1.1 (Serial2), len 100, sending

00:18:53: ICMP type=8, code=0

00:18:53: .

00:18:55: IP: s=140.40.1.2 (local), d=140.40.1.1 (Serial2), len 100, sending

00:18:55: ICMP type=8, code=0

00:18:55: .

00:18:57: IP: s=140.40.1.2 (local), d=140.40.1.1 (Serial2), len 100, sending

00:18:57: ICMP type=8, code=0

00:18:57: .

00:18:59: IP: s=140.40.1.2 (local), d=140.40.1.1 (Serial2), len 100, sending

00:18:59: ICMP type=8, code=0

00:18:59: .

00:19:01: IP: s=140.40.1.2 (local), d=140.40.1.1 (Serial2), len 100, sending

00:19:01: ICMP type=8, code=0

00:19:01: .

Success rate is 0 percent (0/5)

Local#

00:19:00: IP: s=140.40.1.2 (Serial2), d=140.40.1.1 (Serial2), len 100, rcvd 3

00:19:00: ICMP type=8, code=0

00:19:00:

00:19:00: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, sending

00:19:00: ICMP type=0, code=0

00:19:00:

00:19:00: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, encapsulation failed

00:19:00: ICMP type=0, code=0

00:19:00:

00:19:02: IP: s=140.40.1.2 (Serial2), d=140.40.1.1 (Serial2), len 100, rcvd 3

00:19:02: ICMP type=8, code=0

00:19:02:

00:19:02: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, sending

00:19:02: ICMP type=0, code=0

00:19:02:

00:19:02: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, encapsulation failed

00:19:02: ICMP type=0, code=0

00:19:02:

00:19:04: IP: s=140.40.1.2 (Serial2), d=140.40.1.1 (Serial2), len 100, rcvd 3

00:19:04: ICMP type=8, code=0

00:19:04:

00:19:04: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, sending

00:19:04: ICMP type=0, code=0

00:19:04:

00:19:04: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, encapsulation failed

00:19:04: ICMP type=0, code=0

00:19:04:

00:19:06: IP: s=140.40.1.2 (Serial2), d=140.40.1.1 (Serial2), len 100, rcvd 3

00:19:06: ICMP type=8, code=0

00:19:06:

00:19:06: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, sending

00:19:06: ICMP type=0, code=0

00:19:06:

00:19:06: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, encapsulation failed

00:19:06: ICMP type=0, code=0

00:19:06:

00:19:08: IP: s=140.40.1.2 (Serial2), d=140.40.1.1 (Serial2), len 100, rcvd 3

00:19:08: ICMP type=8, code=0

00:19:08:

00:19:08: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, sending

00:19:08: ICMP type=0, code=0

00:19:08:

00:19:08: IP: s=140.40.1.1 (local), d=140.40.1.2 (Serial2), len 100, encapsulation failed

00:19:08: ICMP type=0, code=0

00:19:08:

Local#

Sho run from Local:

Local#sho run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Local

!

enable password cisco

!

!

!

!

!

ip subnet-zero

!

chat-script dial "" "atdt\T" TIMEOUT 60 CONNECT \c

modemcap entry cisco:TPL=AT&F1S0=1&C1&D2&A1&W

modemcap entry ccie:TPL=AT&FS0=1&C1&D3&H1&R2&B119200&M4&K1

!

!

process-max-time 200

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

no ip directed-broadcast

!

interface Ethernet0

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial2

physical-layer async

ip address 140.40.1.1 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer-group 1

async mode dedicated

fair-queue 64 16 0

!

interface Serial3

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial4

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial5

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial6

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial7

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial8

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial9

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface BRI0

no ip address

no ip directed-broadcast

shutdown

isdn guard-timer 0 on-expiry accept

!

ip classless

ip route 1.0.0.0 255.0.0.0 2.2.2.2

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line 2

modem InOut

modem autoconfigure type ccie

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

no login

!

end

Local#

Sho run from Remoto :

Remoto#sho run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Remoto

!

enable password cisco

!

!

!

!

!

ip subnet-zero

!

chat-script dial "" "atdt\T" TIMEOUT 60 CONNECT \c

modemcap entry cisco:TPL=AT&F1S0=1&C1&D2&A1&W

modemcap entry ccie:TPL=AT&FS0=1&C1&D3&H1&R2&B119200&M4&K1

!

!

process-max-time 200

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

no ip directed-broadcast

!

interface Ethernet0

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial2

physical-layer async

ip address 140.40.1.2 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer wait-for-carrier-time 60

dialer string 214

dialer-group 1

async mode dedicated

fair-queue 64 16 0

pulse-time 1

!

interface Serial3

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial4

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial5

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial6

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial7

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial8

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface Serial9

no ip address

no ip directed-broadcast

shutdown

no ignore-hw local-loopback

!

interface BRI0

no ip address

no ip directed-broadcast

shutdown

isdn guard-timer 0 on-expiry accept

!

ip classless

ip route 3.0.0.0 255.0.0.0 2.2.2.1

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line 2

script dialer dial

modem InOut

modem autoconfigure type ccie

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

no login

!

end

Remoto#

Thank You.

Daniel

Silver

Re: string modemcap sportster 56K

Ideally this should work, try adding the authentication between them (though authentication is not a mandatory requirement for PPP)

on Local, add:

username Remoto password cisco

int s2

ppp authen chap.

on Remoto, add:

username Local password cisco

int s2

ppp authen chap.

Thanks, Mak.

153
Views
7
Helpful
8
Replies
CreatePlease login to create content