Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

stuck with ip route- where is the way back?

Can't get this route managed to work, is anybody out there who quickly could help me out?

This is the route I need from LAN to WAN (and back!):

LAN PC 192.168.10.99

Cisco1003 192.168.10.3

Ascend Max1800 192.168.1.28

Firewall 192.168.1.1

WAN

Cisco dials in flawlessly into Max1800.

The Cisco has no problem in pinging and tracing WAN addresses.

The Cisco starts to dial, when PC tries to connect addresses outside the LAN.

The PC sents out the data successfully (checked DNS-Servers logfile).

But no route is built back to the PC.

Pings and traces are running empty behind the Cisco.

Anybody knows what my config is missing? As the Cisco ping/traces nice, I think the error is in the cisco config, not in the ascends.

Any help is appreciated.

The config:

version 11.3

service timestamps debug uptime

service timestamps log uptime

hostname cisco1003

enable password <snip>

username <snip> password <snip>

ip name-server 192.168.1.11

isdn switch-type basic-net3

interface Ethernet0

ip address 192.168.10.3 255.255.255.0

interface BRI0

ip unnumbered Ethernet0

encapsulation ppp

dialer idle-timeout 45

dialer wait-for-carrier-time 10

dialer map ip 192.168.1.28 name <snip> <callno>

dialer load-threshold 200 either

dialer-group 1

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username <snip> password <snip>

ppp multilink

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.28

ip route 192.168.1.0 255.255.255.0 192.168.1.28

ip route 192.168.1.28 255.255.255.255 BRI0

access-list 100 deny ip any host 255.255.255.255

access-list 100 permit ip any any

dialer-list 1 protocol ip list 100

line con 0

line vty 0 4

login

end

3 REPLIES

Re: stuck with ip route- where is the way back?

You are using IP unnumbered on BRI0. The source and destination are not on the same subnet (192.168.10.0 vs 192.168.1.0) This means that a host-route will be built on the ascend, pointing only to the ip adress of the cisco. It does not know about the subnet on which the cisco-eth0 resides.

Regards

Leo

New Member

Re: stuck with ip route- where is the way back?

Thanks, but I didn't get it either.

I changed the subnet of eth0 and gave it a 10.1.1.111, the bri0 now owns the 192.168.10.3.

No return to the PCs in the new subnet (I added ip route 10.1.0.0 255.255.00 Ethernet0)

What do I have to add to the ip routes to get this managed?

TIA

fhals

New Member

Re: stuck with ip route- where is the way back?

The BRI interface has to be on the same subnet at the Ascend you are dialing into. If not, then the Ascend only sees a route to 192.1.68.10.3/32.

You are compounding the problem by adding the additional route. Just make the ethernet interface on the same subnet as the Ascend, and us IP unumbered eth 0 on the BRI. That should work.

105
Views
0
Helpful
3
Replies
CreatePlease login to create content