Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Subinterface problem

Hi!

I got a vlan that was configured on the physical interface previously, and now i'm trying to clear all the config from the physical interface, and move that .9 vlan to int fa0/0.1 and encap it with dot1q. The problem is that after doing this, the .9 vlan is not able to ping any other vlan. The hosts in that vlan can only ping themself. They are not able to ping even their gateway 10.71.9.254(which is the ip/gateway for that fa0/0.1 subinterface).

btw i'm using cisco 2912 router.

Any idea how can i troubleshoot this?

Thks!.

18 REPLIES

Re: Subinterface problem

HI

Can u give more clear view of the problem.As ur question is not that much clear.

Thanks

Mahmood

New Member

Re: Subinterface problem

Hi

The router port connect to a switch, Is the port switch configured as a trunk? Are both using 802.1q?

Are you shure about IP address of host and D.G. are in the same net/subnet?

Please post the configuration of both devices

Regards

Please rate if the post help you.

Albert Giorgi from spain

Re: Subinterface problem

Hi

Can you throw more clarity on the router model in which you are exactly trying to do this config chnage ? also can you post out the current config as well as the show version output taken from the router ..

regds

New Member

Re: Subinterface problem

Hi! The followings are the current config. I'm trying to remove the config in Int fa0/0 and reconfig it in int fa0/0.1 using dot1q and with ip 10.90.9.254 255.255.255.0. After clearing the config in int fa0/0 and reconfigure it in int fa0/0.1 as the rest of the subinterfaces, the .9 vlan can only ping within its own subnet and can't even ping 10.90.9.254.

The router's model is Cisco 2621XM running on ios ver 12.1.

ip subnet-zero

no ip source-route

no ip domain-lookup

!

no ip bootp server

!

!

!

!

!

interface FastEthernet0/0

description Office VLAN

ip address 10.90.9.254 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/0.2

description Management VLAN

encapsulation dot1Q 1

ip address 10.90.8.254 255.255.255.0

no cdp enable

!

interface FastEthernet0/0.3

description Production1 VLAN

encapsulation dot1Q 200

ip address 10.90.10.254 255.255.255.0

no cdp enable

!

interface FastEthernet0/0.4

description Production2 VLAN

encapsulation dot1Q 300

ip address 10.90.11.254 255.255.255.0

no cdp enable

!

interface FastEthernet0/0.5

description Production3 VLAN

encapsulation dot1Q 400

ip address 10.90.12.254 255.255.255.0

no cdp enable

!

interface Serial0/0

ip address 10.90.16.1 255.255.255.0

!

interface FastEthernet0/1

ip address 10.90.13.252 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1

ip address 10.39.1.217 255.255.255.252

!

router rip

redistribute static

network 10.0.0.0

Re: Subinterface problem

HI

i dnot see any encapsulation command under u r interface.can u give it according to u r vlan info.

Thanks

Mahmood

New Member

Re: Subinterface problem

Hi! I've cleared the config in int fa0/0, and move it to int fa0/0.1 as below

interface FastEthernet0/0.1

description office vlan

encapsulation dot1Q 100

ip address 10.90.9.254 255.255.255.0

no cdp enable

Re: Subinterface problem

HI

Can u please verify the port on the switch which u r connecting to u r router is configured as a trunk port and it is having encapsulation configured.

Thanks

Mahmood

New Member

Re: Subinterface problem

Hi! I'm not able to verify right now, as i'm not in the office but i remember there should be trunking for all vlan because if that's not the case the rest of the vlan will not work(eg. .10, .11, .12 and etc).These vlans are working fine, i can ping from one vlan to another. Any other possibility? Thks

Hall of Fame Super Silver

Re: Subinterface problem

David

Were the devices in that VLAN working when it was configured on the main interface (Fa0/0)?

What VLAN are these devices in on the switch? I am guessing that there is a mismatch between the VLAN number used in the router config and the VLAN number on the switch where these devices are connected.

HTH

Rick

New Member

Re: Subinterface problem

Hi!

Yes, it was working when it was on the fa0/0 interface. It's in vlan 100 in the switch.

Thks.

New Member

Re: Subinterface problem

I don't see that you have a native VLan on the routers sub-interface...

encap dot1q vlan 100 native

If you are on the switch, do a

sh cdp nei det

and look at the cdp information at the bottom of the output. It should tell you if you have a native vlan problem. Also make sure that the .9 vlan is not shutdown.

New Member

Re: Subinterface problem

Hi!

Must the native command be in the encap statement?

What is it use for in this case? The rest of the subinterfaces are working fine without the native command. Pls advise.

Thks!

New Member

Re: Subinterface problem

Since the .9 vlan was on the physical interface, the packets were untagged. Now that you put the interface on a subinterface, they must be tagged. Be sure that the switchports native vlan is 100 and that you subinterface you are using on the router for the .9 network has the native keyword for the encapsulation. This should clear up your problem. Let me know.

Hall of Fame Super Silver

Re: Subinterface problem

David

What the native command is used for is to indicate that this VLAN is the native VLAN. Frames in the native VLAN are sent un-tagged and frames in other VLANs are sent framed.

Your config worked when the subnet was configured on the main interface (Fa0/0) because on the main interface frames are sent and received un-tagged. When you moved the configuration to the subinterface (without the native command) the router is expecting frames to be tagged as VLAN 100 but they are un-tagged - because they are in the native VLAN according to the switch.

So when you include the native command on the encapsulation command, it lets the router know that on this subinterface the frames will be un-tagged.

HTH

Rick

New Member

Re: Subinterface problem

Hi! Actually, what's the purpose of using native vlan? Any benefit of using it?

Thks!

New Member

Re: Subinterface problem

Hi!

Can i just delete the .9 vlan and recreate it using other vlan id? eg. instead of using 100, i'll try to use 111. Then i won't be affected by the native vlan anymore. Is my idea right?

New Member

Re: Subinterface problem

Hi!

I've just checked, the native vlan is 1 and it's used by the .8 vlan.

The vlan id used for office vlan is 100 in all the switches.

what i need to do is clear the config on the physical interface and configure the fa0/0.1 as below:

interface FastEthernet0/0.1

description office VLAN

encapsulation dot1Q 100

ip address 10.90.9.254 255.255.255.0

no cdp enable

On the switch's port that's connected to the router, i will need to key in "switchport trunk native vlan 100" and for the .8 vlan assign another vlan id for it.

Am i right?

Will there be any problem to reconfigure the .8 to another subinterface? i meant any effect on the existing subnet/network? (since it's untagged using vlan 1 previously)The .8 network is actually the ip for some of the switches and routers

Here's the config of the connected switch:

set vlan 100 3/1-25,3/27-35,3/37-39,3/41,3/43

set trunk 3/10 nonegotiate dot1q 1-1005

set spantree portfast 3/1-9,3/11-35,3/37-48 enable

what's the set command for "switchport trunk native vlan 100" ?

Thks!

New Member

Re: Subinterface problem

Hi!

Can i just delete the .9 vlan and recreate it using other vlan id? eg. instead of using 100, i'll try to use 111. Then i won't be affected by the native vlan anymore. Is my idea right?

156
Views
8
Helpful
18
Replies
CreatePlease login to create content