Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

subinterface unnumbered problem

I am configuring a 2800 router with a NME-16-1G service module. The service module is in fact a standalone Catalyst 3750 switch and is seen in the router as port gi1/0.

I have created a sub interface of gi1/0 in order to get access to vlan 1 on the switch.

my problem is that if I try to use the ip adress of the loopback 0 interface, it is not working.

If I put the same ip adress on the sub interface, it works.

Configuration that is working :

no interface Loopback0

interface GigabitEthernet1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

!

interface GigabitEthernet1/0.1

encapsulation dot1Q 1 native

ip address 1.2.x.x.255.255.0

phoebe#show vlans

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet1/0.1

This is configured as native Vlan for the following interface(s) :

GigabitEthernet1/0

Protocols Configured: Address: Received: Transmitted:

IP 1.2.3.4 738 0

Configuration what is not working :

interface Loopback0

ip address 1.2.x.x.255.255.0

interface GigabitEthernet1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

!

interface GigabitEthernet1/0.1

encapsulation dot1Q 1 native

ip unnumbered loopback 0

phoebe#show vlans

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: GigabitEthernet1/0.1

This is configured as native Vlan for the following interface(s) :

GigabitEthernet1/0

Protocols Configured: Address: Received: Transmitted:

IP 0.0.0.0 738 0

Is there any possibility to get that working ?

6 REPLIES
Hall of Fame Super Silver

Re: subinterface unnumbered problem

Alain

I am surprised that it accepted the ip unnumbered command on the subinterface. The unnumbered capability is for point to point interfaces. I doubt that there is any way to use it for LAN type interfaces. I am not clear what you are trying to accomplish here. Perhaps if we understood what you are trying to accomplish we might find some other way to do it.

HTH

Rick

Silver

Re: subinterface unnumbered problem

Rick,

I thought so too but in IOS 12.3T IP Unnumbered functionality for VLAN subinterfaces was introduced:

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801d1dfd.html

Hall of Fame Super Silver

Re: subinterface unnumbered problem

Atif

Thanks for posting this link. I was not aware that unnumbered support had been extended to Ethernet interfaces. Learning new things like this is one of the really good things about the forum and one of the reasons I continue to participate.

So it makes the question in the original post more interesting: why is it not working?

- I considered the possibility that the router might not be running code that supported this feature (introduced in 12.3(4)T so it needs to be pretty recent code) but the fact that the router accepted the command seems to indicate that the code does support it.

- I note that the link you posted describes one requirement being that DHCP is configured and active. It is not clear in the original post whether DHCP is configured and active or not.

- I considered whether the fact that the address does not appear in the output of the show command is really a sign that unnumbered is not working. Does the interface pass traffic? Can the router communicate with devices in that VLAN?

HTH

Rick

Silver

Re: subinterface unnumbered problem

Hello Rick,

Yes this forum is indeed one of the best ways to stay in touch with new features especially for people who are not directly involved in hands on.

As far as the poster's problem is concerned I guess we will wait till he responds to your post as I believe you have covered pretty much everything (as usual) :)

Atif

New Member

Re: subinterface unnumbered problem

I have solved my problem. In fact the solution is obvious : what you need to do is to put a /32 ip adress to the loopback interface and then add a route for the subnet through the subnet.

So the working config is :

interface Loopback0

ip address 1.2.3.4 255.255.255.255

interface GigabitEthernet1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

!

interface GigabitEthernet1/0.1

encapsulation dot1Q 1 native

ip unnumbered loopback 0

ip route 1.2.3.0 255.255.255.0 GigabitEthernet1/0.1

Hall of Fame Super Silver

Re: subinterface unnumbered problem

Alain

Thank you for posting to the forum with the solution to the problem. It helps make the forum more useful when we can read about a problem and then see what the solution to the problem was.

And I agree that the solution seems pretty obvious - once you have identified the solution (and agravating until you do identify it).

HTH

Rick

411
Views
5
Helpful
6
Replies