Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Subnetting and Routing

Hi there,

I have a network that's comprised of 2 non-continginous /24 (65.202.119 and 65.202.69) networks and are about to have to release these two /24's back in exchange for a contingous /20. (206.113.64.0/20). I have a few questions. I guess the best place to start is the top so here goes.

What is the best way to have subnetted /24's (and smaller subnets) behind ADDITIONAL routers that may exist on fastethernet0/0's network?

I have read documents for the last week and I still have questions. I have printed and read the following and several others:

IP Addressing and Subnetting for New Users

Configuring IP Addressing

Configuring IP Routing

Advanced Routing Technologies (Slides)

Configuring BGP

The problem I keep running into is that the examples do not use contingous IP blocks so I keep confusing myself as to how I need to do this. Any help is greatly appreciated.

Coming inbound from the net we have two .252 networks. These are configured by the upstream provider for redundant T1's and are not part of the /20.

interface Serial0/0.1 point-to-point

ip address 65.208.87.142 255.255.255.252

interface Serial0/0.1 point-to-point

ip address 65.208.87.146 255.255.255.252

Here's the network now with the /20 working but I think we need something different.

interface FastEthernet0/0

! I have tried putting just a /24 here and then having static routes for

! other /24's. It did not work....

ip address 206.113.64.1 255.255.240.0 secondary

ip address 65.202.119.1 255.255.255.0

router bgp 1234

bgp log-neighbor-changes

network 65.202.69.0 mask 255.255.255.0

network 65.202.119.0 mask 255.255.255.0

! I think this is where my problem also occurs.

! See futher below...

network 206.113.64.0 mask 255.255.240.0

neighbor 65.208.87.141 remote-as 321

neighbor 65.208.87.145 remote-as 321

neighbor 65.208.87.145 route-map shadow in

neighbor 65.208.87.145 route-map shadow out

route-map shadow permit 10

set metric 10

ip classless

ip route 65.202.69.0 255.255.255.0 65.202.119.14

ip route 65.202.119.0 255.255.255.0 FastEthernet0/0

! An example of trying to put a smaller subnet of the /20 here.

! It seems to be working but see further below....

ip route 206.113.72.0 255.255.248.0 206.113.65.7

This is why I think it's broken...

It shows the entire /20 on eth0. So it's doing mac address layer 2 switching rather than IP routing yes?

gw-1#sh ip route

Gateway of last resort is 65.208.87.141 to network 0.0.0.0

65.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C 65.208.87.140/30 is directly connected, Serial0/0.1

C 65.208.87.144/30 is directly connected, Serial0/1.1

S 65.202.69.0/24 [1/0] via 65.202.119.14

C 65.202.119.0/24 is directly connected, FastEthernet0/0

B* 0.0.0.0/0 [20/0] via 65.208.87.141, 2d14h

C 206.113.64.0/20 is directly connected, FastEthernet0/0

S 206.113.72.0/21 [1/0] via 206.113.65.7

So, should I add in the bgp router config an aggregate route with summary only to suppress the smaller routes from being announced back upstream? For example,

aggregate address 206.113.60.0 255.255.240.0 summary only

!Then list the other subnets (For example...)

network 206.113.79.0 mask 255.255.255.0

network 206.113.78.0 mask 255.255.255.0

Also, do I need a static route entry for each of these? I think I do but I just want to make sure.

In summary, my thoughts are that for each subnet I put on fastethernet0/0 and for each static route I enter I also need a network line in the router bgp config, along with an aggregate-address / summary only line for the /20 as a whole.

Thanks,

Lewis

4 REPLIES
Cisco Employee

Re: Subnetting and Routing

Here's the way most people do it.

router bgp 1234

network 206.113.64.0 mask 255.255.240.0

ip route 206.113.64.0 255.255.240.0 null0

This will advertised the /20 to the Internet as long as your router is up and running therefore maximizing the stability of this prefix on the Internet, which is what everybody should be doing.

Afterward you can basically subnet the /20 any way you want internally using static routes or a routing protocol and all that is transparent to the Internet.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Anonymous
N/A

Re: Subnetting and Routing

Hi HRitter,

Thanks for the help. I currently have it working as far as the /20 being passed back upstream (according to sh ip route and sh ip bgp commands) and this agrees with what I have read. I understand that fully but it's not directly my question. Please see more below.

. I have tried using statics (for instance /24's) and a different /24 on fastethernet0/0. The result was where a machine that was behind the 2nd router could only pass packets not beyond the fastethernet network. So.. I have been considering adding some bgp configs to help...

aggregate address x.x.x.x summary-only

and several other subnets within the bgp configuration.

This is what I am trying to determine will make it work. In other words... only having static routes didn't work. Any advice you can give me I appreciate much.

Thanks,

Lewis

Cisco Employee

Re: Subnetting and Routing

Lewis my point was that you shouldn't configured the /20 on the Fa0/0 but simply a ststic route for the /20 pointing to null0. You should start by changing this piece of your configuration. You should not need to add to your BGP configuration. Try using a /24 (or whatever is needed on the Fa0/0) and use static routes to reach subnets behind Fa0/0. Also make sure that the subnets behind Fa0/0 have a default gateway pointing back at your Internet facing router.

Let me know if it helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Anonymous
N/A

Re: Subnetting and Routing

Hey there,

Initially I tried a /24 on fe0/0 and other /24's as static routes failed. I made sure that I had also clear ip route * and clear arp-cache so that an old route was not causing the problem. The difference was that I did not have a /20 pointing to /dev/null.

For instance I had 206.113.64.1 255.255.255.0 configured on fe0/0 and had a static route for 206.113.79.0/24 at 206.113.64.2. This never would make it out. Before your post I was able to get it working by adding the bgp network configs including the aggregate / summary lines as well as the individual lines for the /24's.

Both ways we now have the whole /20 pointing to /dev/null with the specific routes looking good.

Thanks for posting.

Lewis

160
Views
0
Helpful
4
Replies
CreatePlease to create content